WordPress.org

Ready to get started?Download WordPress

Forums

can't connect to database when trying to install (6 posts)

  1. project2501
    Member
    Posted 7 years ago #

    Hi there... trying to install wordpress on a godaddy server. I've set up the mySQL database and downloaded wordpress. I modified the config file with the DB name, username and password. I left the server at 'localhost'. Now when I try to connect to install.php to run the installation I get the error:

    "Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums."

    I have re-created the DB with a new name and username but I get the same result. I've also changed "localhost" to ( I think) the specific IP address of the server the DB is running on. Has anyone else had any problems with Go Daddy? I don't know what to do next... any help would be greatly appreciated.

    Thanks

  2. kenonline
    Member
    Posted 7 years ago #

    I have the same problem, i could not connect to the local host...what are the other options?

  3. 4k
    Member
    Posted 7 years ago #

    here is an tutorial on installing wordpress on godaddy

    it's always worth double checking too that you didn't add in a space between your info and the single quotes watch for 'password' not ' password'

  4. wendyhouse
    Member
    Posted 7 years ago #

    I have installed wordpress in a directory called wrodpress
    I get the same error when I use type this url:
    http://hilarypalmen.com/wordpress/wp-admin/install.php

    I have verified my config file details are correct, checked for spaces, tried signing-in directly to my php database from the Hosts UI with the user credentials in the config file - this works.

    Is there some other common error I'm making? Do I need to make any other adjustments when installing in a directory? Thanks

  5. MichaelH
    Member
    Posted 7 years ago #

    Well you are using localhost for your DB_HOST and Godaddy will have a DB_HOST such as 'h50mysql20.secureserver.net' (that's an example of one of Godaddy's MySQL 5.0 servers)

    But more important, you should upgrade your plan because WordPress doesn't work correctly with those 'free with domain' type plans.

  6. wendyhouse
    Member
    Posted 7 years ago #

    Michael, thankyou so much for a prompt and easy to understand reply. Problem solved.

    in config file I changed 'localhost' to the name of the DB Host published in the GoDaddy web UI.

Topic Closed

This topic has been closed to new replies.

About this Topic