WordPress.org

Ready to get started?Download WordPress

Forums

Can't click on links (8 posts)

  1. mooses
    Member
    Posted 9 years ago #

    After changing my layout, I've developed an odd problem, and I have no idea how to go about fixing it. I'll try and explain it coherently: any links or text boxes that appear in the first quarter of the main section aren't recognised - there's a big unclickable region. So if post titles aren't long enough you can't click on them. If the (more...) tag is on the left, you can't click on that either. And when you go to the comments section, the text boxes can't be selected unless you click on the far right. (This is all behaviour in Firefox)

    Exceptions: In Firefox, if you are viewing a single post that has a (more...) tag in it, everything seems to work fine. And in IE, none of the above behaviour seems to apply, although the layout is completely snafoo.

    If anyone could point me in the right direction, I'd be very happy. The site is at http://evilmoose.shafted.com.au and the css can be viewed at http://evilmoose.shafted.com.au/wordpress/wp-layout.css

  2. serendipity
    Member
    Posted 9 years ago #

    It's the way you get your menu to the right, using margins exclusively and no positioning whatsoever. So the menu leaves a sortof ghost behind that overlaps the part of the page where it would be.

    Try this: replace margin: -96px 0px 0px 600px; for #menu with position: absolute; left: 600px; top: -96px;. That's not ideal -- you might have to redo your rounded corners for the menu -- but the links in the content area become clickable.

    You may be interested in studying two-col layouts and getting the webdeveloper extension for Firefox.

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Go here:
    http://www.squarefree.com/bookmarklets/webdevel.html

    Drag the "Show blocks" and "Topographic View" bookmarklets to your sidebar / favourites

    Return to your page

    Click both the new bookmarklets ...... and then say "Where on earth have they come from ?????

    You seem to have a hidden set of page elements that although cunningly disguised, are interfering with the linkage. Sort those out - and I assume they are in your index (which you should backup first) so you'll need to edit that.

  4. serendipity
    Member
    Posted 9 years ago #

    Podz: 1 sec :)

    (Podz is right, but the "hidden element" is your menu.)

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    serendipity 1:0 podz

    :p

  6. mooses
    Member
    Posted 9 years ago #

    Thanks a lot guys - I thought it had something to do with the way I sorted out my menu. Now I know where to start fixing things! I'll update and let you know how it works out. Thanks again :)

    EDIT 2 minutes later: That fixed up the menu. Now I have to get the menu bottom corners back to where they're supposed to be, and find out why the footer is sitting so high up if I add it in. It sits right underneath where the div=rap finishes, which is very high. Possibly a problem with the rap div. I'll try and sort it out myself before asking more questions.

  7. pman12345
    Member
    Posted 8 years ago #

    I'm having the same problem but can't seem to figure it out. It doesn't help that I'm not a savy programmer. My Submit button in the Comments is disabled in Firefox. I really would love some help here. I don't even know where to begin.

    You can check out my site at http://theywantpie.com. Try to add a comment to any of the posts with Firefox and you'll see the problem. :0(

    I hope someone can help!

    Thanks a lot in advance guys!

  8. Penda
    Member
    Posted 8 years ago #

    PMan - We have the same template and I have the same problem. All links on the container portion are disabled. The side bar links work fine, but I understand why I'm not getting comments from people now, especially if they're using FF.

    Is anyone out there?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.