WordPress.org

Ready to get started?Download WordPress

Forums

Can't change WordPress address (URL) (9 posts)

  1. alicat
    Member
    Posted 3 years ago #

    Why won't WordPress let me alter the URL!? The field is grey and uneditable--very frustrating that I can't change site location. Is this a problem with version 3.1?

  2. jonradio
    Member
    Posted 3 years ago #

    The only reason that I'm aware of that would make the two fields (WordPress address (URL) and Site address (URL)) greyed out is if define('WP_SITEURL', and/or define('WP_HOME', are coded in wp-config.php

  3. alicat
    Member
    Posted 3 years ago #

    Yes, I think you're right. Bluehost is hosting the Website in question, which is highly recommended by WordPress. So I am wondering why Bluehost isn't being very compatible with WordPress when it comes to moving a wordpress site. I didn't ever make any changes within Bluehost's wp-config.php file.

    Has anyone else had this complication?

  4. Chris_K
    Member
    Posted 3 years ago #

    As soon as you edit the wp-config.php and remove those hard-coded URL statements the problem goes away... Of course, be sure to back up a copy of that file before editing.

    I could be wrong, but I'm not aware of any hosts automagically putting those statements in the wp-config. (not defending BlueHost here, but perhaps you're jumping to the wrong conclusion). Did you or somebody else recently move or migrate your WordPress install? The Moving_WordPress documentation mentions using those statements, perhaps someone did and neglected to remove them when done.

  5. alicat
    Member
    Posted 3 years ago #

    You're losing me there... I had to follow Bluehosts instructions on manually changing the URL address, which worked just fine. I still don't quite understand why I couldn't do that through WordPress's admin panel, which would have been way easier and about 2 hours less time for me to figure out what the heck was going on. Also, nobody moved or migrated the WordPress site prior to this latest attempt. So, I still don't quite understand how it came to be greyed out in the WordPress panel. Thanks for your input.

  6. trusktr
    Member
    Posted 3 years ago #

    I'm having this problem, except i don't have WP_SITEURL and WP_HOME hardcoded into my wp-config.php.

    How the heck do I get rid of this annoying problem?

  7. ZeroGravity
    Member
    Posted 2 years ago #

    SOLVED!!!

    Not content for a work around I went digging. I also don't have WP_SITEURL or WP_HOME set in my wp-config.php. I guessed it might have been a plugin and sure enough, Bingo!!!

    I use stray random quotes to put testimonials on a site (love this plugin). The way it works it needs to disable changing the address URL otherwise it would break. I haven't checked the documentation fully to see if it is mentioned. I disabled the plugin, moved the site, then activated the plugin again. All the settings and quotes were still there.

    I hope this helps, there may be other plugins that do the same. Hopefully authors will start prominently documenting this to save some heartache.

  8. haocreative
    Member
    Posted 2 years ago #

  9. haocreative
    Member
    Posted 2 years ago #

    @ adiant – The only reason that I'm aware of that would make the two fields (WordPress address (URL) and Site address (URL)) greyed out is if define('WP_SITEURL', and/or define('WP_HOME', are coded in wp-config.php

    @Chris K "As soon as you edit the wp-config.php and remove those hard-coded URL statements the problem goes away... Of course, be sure to back up a copy of that file before editing." I've done this but it doesn't seem to go away.

    It's hosting with godaddy.

Topic Closed

This topic has been closed to new replies.

About this Topic