WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't change WordPress Address URL (10 posts)

  1. garfonhdz
    Member
    Posted 4 years ago #

    I changed my site domain, it first was http://es.wats-on-emma.com but I didn't like it so I bought http://www.bestemma.com and I want that one to be my new WordPress Address URL but when I try to edit it in Settings, I get this:

    http://www.bestemma.com/error.png

    Can someone tell me how can I change that field?

    Thank you

  2. doc4
    Member
    Posted 4 years ago #

    garfonhdz,

    Did you move the files to the new domain directory following the WordPress walkthrough: http://codex.wordpress.org/Moving_WordPress? This details everything necessary for a successful move. Let us know.

  3. garfonhdz
    Member
    Posted 4 years ago #

    I'm sorry if I'm doing something wrong, but I'm not advanced user, here's what I did:

    The WordPress directory wasn't moved lets say it is /public_html/bestemma/. And I haven't moved it from there. When I used http://es.wats-on-emma.com it was installed in that same place, the only thing I did was buy a new domain. That domain is already pointing to /public_html/bestemma/. Let's say you go to: http://www.bestemma.com You can enter the site, but when I try to access the admin, the address turns to: http://es.wats-on-emma.com/wp-admin/ and I would like it to be http://www.bestemma.com

    That's what is happening, I don't know whats going on. I can't edit the WordPress Address URL field... Please let me know if I'm doing something wrong.. :S

  4. garfonhdz
    Member
    Posted 4 years ago #

    Any ideas?... :S

  5. doc4
    Member
    Posted 4 years ago #

    garfonhdz,

    You will still need to read through the Moving WordPres instructions. The issue is that it appears you have not changed your WordPress URL and Blog URL before pointing to the new domain. There is a fix for this on the instruction page.

    We understand that you may not be an expert and it's okay.

    "It is important that you set the URI locations BEFORE you move the files.

    Suppose you accidentally moved the files before you changed the URIs: you have two options.

    OPTION 1. Suppose the files were originally in /path/to/old/ and you moved them to /path/to/new before changing the URIs. The way to fix this would be to make /path/to/old/ a symlink (for Windows users, "symlink" is equivalent to "shortcut") to /path/to/new/, i.e.

    ln -s /path/to/new /path/to/old

    and then follow the steps above as normal. Afterwards delete the symlink if you want.

    OPTION 2.If you forget to change the WordPress Address and Blog Address, you will be unable to change it using the wordpress interface. However, you can fix it if you have access to the database. Go to the database of your blog and find the wp_options table. This table stores all the options that you can set in the interface. The WordPress Address and Blog Address are stored as siteurl and home (the option_name field). All you have to do is change the option_value field to the correct URL for the records with option_name=’siteurl‘ or option_name=’home‘.

    You're done. Test your site to make sure that it works right. If the change involves a new address for your blog, make sure you let people know the new address, and consider adding some redirection instructions in your .htaccess file to guide visitors to the new location."

    All of this information and more is available through the link above.

  6. garfonhdz
    Member
    Posted 4 years ago #

    Thank you I finally got it right. http://www.bestemma.com

  7. leehammack
    Member
    Posted 4 years ago #

    I'm having a similar problem. I followed the walkthrough - but on the "General Settings" page the boxes for "WordPress address (URL" and "Blog address (URL)" are grayed out - I can highlight them in blue but nothing changes if I start typing. (It must be some dumb mistake.) Also - in this forum I see the acronym "URI" where it seems like you mean "URL" - is that a typo or is URI something else?

    Thanks
    Lee Hammack

  8. Aldi
    Member
    Posted 4 years ago #

    @leehammack:

    The same thing happened to me but I managed to find a fix. The procedure that I followed came from here:

    http://codex.wordpress.org/Changing_The_Site_URL

    If I followed the first method, ie. edit wp-config.php, the input boxes are grayed out. I assumed that this method doesn't create a permanent fix in that if I delete the 'fix code', the error will return. Thus, the 'fix code' shouldn't be deleted.

    So I tried the second method, ie. the quick fix method (edit functions.php), the problem is solved and the boxes aren't grayed out, even after you delete the 'fix code' afterward.

  9. Maarten
    Member
    Posted 4 years ago #

    thanks doc4! saved me from reinstalling...

  10. divyesh.sanghani
    Member
    Posted 3 years ago #

    Hello,

    i configure blog @ http://guj.krutarth.com

    which is redirected @ http://www.krutarth.com/Gujarati/index.php

    but when my default blog url is http://www.krutarth.com/Gujarati

    Actully i want to add default home url http://www.krutarth.com/Gujarati/index.php

    i mean that when i open http://www.krutarth.com/Gujarati that time this link i want to redirect at http://www.krutarth.com/Gujarati/index.php

    so, how can i add index.php as default home page. which is show at addressbar.

Topic Closed

This topic has been closed to new replies.

About this Topic