WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't change WordPress address (URL) (10 posts)

  1. lfellows
    Member
    Posted 4 years ago #

    I'm trying to move WP to a different subdomain, using the codex ("Moving WordPress Within Your Site"). However, when I go to Settings > General, the "WordPress address (URL)" field is greyed-out and I can't change it. How can I unlock it? Do I need to change it in the database tables?

  2. doc4
    Member
    Posted 4 years ago #

    Ifellows,

    Are you using a WordPress blog hosted by WordPress? If this is the case you should ask this question at http://www.wordpress.com.

  3. lfellows
    Member
    Posted 4 years ago #

    No, doc4, I'm hosting my own blog on 1&1, using WP version 2.8.3.

  4. lfellows
    Member
    Posted 4 years ago #

    For anyone else similarly situated, the work-around is to edit the wp-config.php file, to define both the "WP_SITEURL" and the "WP_HOME" values. (See "Editing wp-config.php," under "Advanced Options.")

    Setting these values overrides whatever's in the database table.

    Keep in mind after you do this that both fields will now be blocked (greyed-out) under Settings > General. If you want to change the values again in the future, you'll have to re-edit the wp-config.php file.

  5. Netdetective
    Member
    Posted 4 years ago #

    I am having the same problem. Is it possible to restore it, so those 2 lines are not greyed out?

    Fred

  6. ChrisCree
    Member
    Posted 4 years ago #

    Netdetective, All you have to do is edit the wp-config.php file again and delete those two lines that lfellows mentioned above. Obviously you'll want to save a copy of your wp-config file before you make any changes so if something breaks you can put it back the way it was.

  7. lmilesw
    Member
    Posted 4 years ago #

    I have the same issue and realize I can edit the wp-config.php but is there a way to restore the editability within the General Settings area fo WP? Do I have to edit the MySQL Db?

  8. dubjohnston
    Member
    Posted 4 years ago #

    Worked perfectly for me.. thanks Ifellows..

  9. Mykiko85
    Member
    Posted 3 years ago #

    Thanks, great advice on here. I have now resotred my site URL to it's original value, but I can only access the home page of my site, and the dashbaord. Any ideas?

  10. Mykiko85
    Member
    Posted 3 years ago #

    Figured it out. After changing the site URL, to undo the changes that caused the 404 error the .htaccess file needed to be removed from the new location (which was the root directory in my case). So now my site is back to how it used to be.

Topic Closed

This topic has been closed to new replies.

About this Topic