WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Can't change Titles and Descriptions (13 posts)

  1. sdaveCL
    Member
    Posted 1 year ago #

    WordPress 3.5
    Plugin 1.3.4.4

    First, I believe I'm only seeing this behavior on one client site.

    What is happening is when trying to change the existing title or description on a page/post it does not save it when clicking Update. When the page refreshes, the old title and description is still present. I have confirmed that the page is not being updated by checking the <head>.

    I've tried disabling all plugins. No success.

    Switching back to a default WordPress theme fixes the problem. Everything continues to work fine when I switch back to the preferred theme but only temporarily. Why would it work for a while, then stop?

    I didn't see any errors in console last time this problem popped up. Unfortunately I neglected to check again this time. Switching back and forth between a default WP theme fixed it again, but I don't know how long that will last.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. mikeotgaar
    Member
    Posted 1 year ago #

    Would you enable wp_debug - see here for how-to - http://codex.wordpress.org/Debugging_in_WordPress
    and this for guide to use a browser to find errors: http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors
    Turn off any caching systems!
    Post the error message info here - also look for Warnings and Notices appearing above and within your page and included the info
    (or leave wp_debug active and post a link to your site so Yoast and other contribs can look for themselves)
    Thanks

  3. sdaveCL
    Member
    Posted 1 year ago #

    I've turned on debug mode (with displaying of messages off) and am using the Debug Bar plugin to monitor.

    If/when the problem pops up again I'll post the ensuing error messages.

    All I see right now are several "Undefined index" errors from other plugins, which I can only assume are unrelated because when I disable all plugins except WordPress SEO it still does not allow me to update titles and descriptions.

  4. sdaveCL
    Member
    Posted 1 year ago #

    Changes made in meta box are not saving again.

    I'm not seeing any errors in Chrome or in the WordPress Debug console.

    Again tried deactivating all plugins but WordPress SEO to no avail. Problem occurs in all browsers.

    I'm having a hard time understanding how this problem could come and go, why changing the themes back and forth from default would fix it but only temporarily.

    I should also mention that I have other websites hosted with the same hosting company that are not having this problem.

  5. stmarie
    Member
    Posted 1 year ago #

    I'm having the same issue on a site. I rebuilt the site using a Twenty Twelve child theme, and the problem went away for a bit but is happening again. Disabling all plugins except for WordPress SEO doesn't fix the issue... nor does disabling the child theme.

  6. tonyallsopp
    Member
    Posted 1 year ago #

    I am having the same problem. Have previously entered keywords, title and description on a few pages, but now I can't edit them. Whatever changes I make it does not save them.

    I don't want to disable my theme as it removes all the widgets from the position their in, and I have to rebuild them all. Rubbish I know, but that's life.

    Do you have any other ideas how this can be edited? I'd be happy to change the data directly in the database through PHP MyAdmin if you point me in the right direction of where to look?

  7. stmarie
    Member
    Posted 1 year ago #

    Unfortunately, since this is a client site, I just removed the Yoast plugin and switched to All in One SEO. That plugin seems to be working and keeping the info we're entering.

    I hope each of you figures out a solution!

  8. sdaveCL
    Member
    Posted 1 year ago #

    Seems quite a few people are having this problem.

    http://wordpress.org/support/topic/page-seo-section-not-saving

  9. axelay
    Member
    Posted 1 year ago #

    Hey all,

    I think I found a solution to this problem but as I am truly a newbie when it comes to WordPress coding, I thought I'd share with you to confirm.

    In the plugins/wordpress-seo/admin/class-metabox.php file, I commented out lines 691 and 692. Now I am not sure what this wp_is_post_revision(...) function actually does apart from what I learnt from reading the WP docs.

    Hope that helps somebody!

    a.

  10. master412160
    Member
    Posted 1 year ago #

    Hey all,

    I think I found a solution to this problem but as I am truly a newbie when it comes to WordPress coding, I thought I'd share with you to confirm.

    In the plugins/wordpress-seo/admin/class-metabox.php file, I commented out lines 691 and 692. Now I am not sure what this wp_is_post_revision(...) function actually does apart from what I learnt from reading the WP docs.

    Hope that helps somebody!

    a.

    That did the trick! Thank you very much sir.

    I hope in next plugin update Yoast fixes this issue.

  11. hoppylorinc
    Member
    Posted 9 months ago #

    WP 3.5.1
    Wordpress SEO 1.4.12

    Problem still not solved. I tried axelay's hack on lines 712-713 (wp_is_post_revision seemed to move here from 691-692), it does not fix the issue.

    BTW, are we talking about this?

    //  if ( wp_is_post_revision( $post_id ) )
    //	  $post_id = wp_is_post_revision( $post_id );
  12. Net Admin
    Member
    Posted 9 months ago #

    I have figured out a work around for the issue of the home page meta description not changing.

    Go to import/export and export your settings. It will save a file named settings.zip. Inside is a settings.ini where you can make the necessary changes (mine was after "metadesc-home ="). Save that settings.ini file and recompress to settings.zip Import the updated settings.zip file, and my home page meta description is now changed.

  13. jrf
    Member
    Posted 9 months ago #

    Hi all,

    I'd like to look into this issue, but I can not reproduce the problem on WP 3.5.2, WP SEO 1.4.13 with theme: twentytwelve.

    The more info I get, the better chance there is that I can solve it.

    So for those willing to help get this fixed, please give me as much information as you can for the following questions:

    1. What theme are you using when the problem occurs ?
    2. Does it still occur using one of the WP default themes ? (some say it does, some say it doesn't)
    3. Does it still occur if all other plugins are deactivated ?
    4. What - if any - PHP error messages do you see in your error log ? or on the screen/in the page source if you have WP_DEBUG enabled ?
    5. What - if any - Javascript errors do you see in the JS console ?

    Please only post errors which relate to WP SEO!

    If you are currently not logging PHP errors, have a look at this code which you can add to your wp-config.php file.
    It will log any and all php errors to a file, independently of whether you have WP_DEBUG set to true. That way you can keep track of PHP issues on a live website.

    I'd be very interested to hear if any errors relating to this issue show up in the log.

    Be aware: logging errors will generally scare the living daylights out of most people as they suddenly start realising how many plugins are throwing errors....

    Look forward to hearing more.

    Smile,
    Juliette

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.