WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't change theme (24 posts)

  1. savedave
    Member
    Posted 1 year ago #

    Hi there

    I am using twenty-eleven (child theme) and was recently suggested that twenty twelve might suit my needs better.

    For some reason, in the appearance tab of my dashboard, I cannot seem to change theme. I click on activate on twenty twelve and I get this announcement at the top of the page "New theme activated. Visit site" but the dashboard still says Twenty Eleven Child is active and when I visit the site, it still is twenty eleven child.

    Am I doing something stupid?

    thanks kindly,

    SD

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Do you have caching on your site?

  3. savedave
    Member
    Posted 1 year ago #

    oh. Sorry WP yogi, I don't know. Apologies - I am relatively new to this game...

    I have disabled the cache on the browser if that makes any difference.

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    No problem :) - it's not visible on your site - which it often would show a cached page. It would be under plugins - SuperCache or W3TC are common ones. But it sounds like maybe something else is going on. Can you deactivate whatever plugins you do have?

  5. savedave
    Member
    Posted 1 year ago #

    I dont have those plugins.

  6. savedave
    Member
    Posted 1 year ago #

    quick question before I deactivate the others. Will the data within the plugins be saves - the settings etc. For example in the SEO plugin, I have added literally tons of info that will take hours to re-enter if it is lost.

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yes, those settings "should" be saved so far as I know - though I've not used that plugin. But it's always a good idea to backup your site before starting to troubleshoot a problem like this.

    What browser are you using? Try switching to another to see if that makes any difference. Also, where is your site hosted - some hosts use caching.

  8. savedave
    Member
    Posted 1 year ago #

    Ok, I'll start by changing browser. I am using chrome - I'll try safari...

  9. savedave
    Member
    Posted 1 year ago #

    changing browser has no effect.

  10. savedave
    Member
    Posted 1 year ago #

    hosting company says there are no caching issues

  11. savedave
    Member
    Posted 1 year ago #

    Ok so I am trying to deactivate the plugins and I cannot! I have the exact same issue as I have with the themes. I first noticed something like this earlier today when I tried to deactivate the "custom sidebars" plugin, though I cannot say if that plugin is responsible as I had not tried to deactivate anything or change theme prior to today.

    Can you help? this is a bit of a stress now!

  12. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @savedave - okay - you'll need to use FTP (or other file manager) to deactivate your plugins - find the plugins folder and change the name to "pluginsHOLD".

  13. savedave
    Member
    Posted 1 year ago #

    Thanks WPyogi.

    I have done that, and the plugins have deactivated (with appropriate warnings). But I still can't change theme.

    Any thoughts?

  14. savedave
    Member
    Posted 1 year ago #

    What about if I similarly deactivate my theme?

    Though I'd like to reach a point where the ability to change themes and plugins works normally again... no idea how this happened. Only other thing I think is that today at the suggestion of my hosting company I used myphpadmin to optimise the database.

  15. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yes, that would be the next step to try.

  16. savedave
    Member
    Posted 1 year ago #

    ok. i am finding this scary
    here goes.

  17. savedave
    Member
    Posted 1 year ago #

    Ok So I did that.

    the dashboard said it is reverting to the default theme as the active theme is broken. Which is to be expected. And it now says that twenty twelve is active.

    But nothing loads when I open a page. Just blank pages.

    http://www.nadaav.com/n

    gasp!

    any thoughts?

  18. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Only other thing I think is that today at the suggestion of my hosting company I used myphpadmin to optimise the database.

    Do you have a back-up from before that?

    You can also try downloading a new copy of WP to your local computer and then deleting all files/folders EXCEPT wp-content on your site and replacing them with new ones - again, don't overwrite wp-content.

  19. savedave
    Member
    Posted 1 year ago #

    no - I dont have a backup myself. The hosting company told me it would have no negative effect and would only speed up access to the site. and silly me believed them.

    I also did this to my other sites too.

    do you think this is the cause?

  20. savedave
    Member
    Posted 1 year ago #

    Meanwhile I will try what you have suggested.

    I dont know how to download a copy of WP to my local computer though. Do you have a guide for that? I have only ever installed it via the software on my server

  21. savedave
    Member
    Posted 1 year ago #

    All a bit random - some how, for no apparent reason, everything started working again. I am a little scared this might happen again!

  22. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    It may have been a server glitch or possibly that deactivating the plugins and theme finally "took." These things happen - no way to totally avoid them - as there are many variables beyond your control :). Servers, internet connections, your local computer...

    But at least this seems to be rectified - hooray for that!

  23. savedave
    Member
    Posted 1 year ago #

    Yes I know. massive sigh of relief. Computer not quite thrown out of window etc! :)

    thanks for your help.

  24. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    LOL - yes indeed. I'm glad you and your computer aren't out any windows. But BTW, always make a backup before you ever mess with a database...just in case :)!

Topic Closed

This topic has been closed to new replies.

About this Topic