WordPress.org

Ready to get started?Download WordPress

Forums

Cant change PHP (22 posts)

  1. slowhost
    Member
    Posted 2 years ago #

    Hello all,

    I`ve recently changed servers and need to update the pages on my site, but each time i try to update the PHP is a post or page it will not update and either goes to a page saying this if i try updating or previewing page :

    This error (HTTP 501 Not Implemented or HTTP 505 Version Not Supported) means that the website you are visiting doesn't currently have the ability to display the webpage, or support the HTTP version used to request the page.

    Or when i try to update it in a widget, the update circle will just spin for as long as i leave it..

    any suggestions? ive tried this 100s of times still the same outcome,

    tried deactivating all plug in`s still nothing.

    Thanks for any help

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Try contacting your hosts for assistance.

  3. slowhost
    Member
    Posted 2 years ago #

    Hi,

    I did contact them at the first hurdle but they said it must be a wordpress issue, although they didnt look into it for me and wernt helpfull at all...

    Any other suggestions??

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you:

    - switched to the Twenty Eleven theme to rule out any theme-specific problems?

    - reset the plugins folder by FTP or PhpMyAdmin?

  5. slowhost
    Member
    Posted 2 years ago #

    Just both of them, still no change.

    Really frustraighting any other ideas??

    Thanks again for the help

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    I'm sorry but it really does sound like a server issue - not a WordPress one.

  7. slowhost
    Member
    Posted 2 years ago #

    I rang the hosting company and they said that because wordpress is a 3rd party add on, they dont offer support for it...

    so i`ve asked them if it could be anything to do with the server or hosting and they said everything is fine and working as it should be.

    Dont know what else i can ask them?!??!??

  8. jimmerd
    Member
    Posted 2 years ago #

    Who is the hosting company? Do they promise PHP5 and MySQL?

    Have you tried uploading a PHPinfo file?

    Just make a file with the following PHP:
    <?php phpinfo(); ?>
    save as phpinfo.php
    upload to your server's web root
    go to yourdomain.com/phpinfo.php

    This will list all PHP info and may help you (and/or us or your host) solve the problem.

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    Did you give them copies of the error messages?
    These are both clearly server issues
    http://www.checkupdown.com/status/E501.html
    http://www.checkupdown.com/status/E505.html

    If they continue to refuse to investigate further, start looking for a new hosting company. We can all do without bad hosts.

  10. slowhost
    Member
    Posted 2 years ago #

    The hosting company ive moved to is called xilo, ive rang 3 times today asking if they could help me out with my problem, they didnt even look it up just said it cant be anything to do with the hosting and WordPress is a 3 party so ask them to sort it out!!

    basically just blanked me no help what so ever, no support what so ever!!

    When i was with fasthosts, they would have looked and helped me sort the problem straight away, whilst on the phone!!

    I`ve tried to do as you said with the file you suggested and this is the responce i get :

    Warning: phpinfo() has been disabled for security reasons in /home/exercise/public_html/phpinfo.php on line 1

    Does this make sense???

    Thanks again for the help

  11. jimmerd
    Member
    Posted 2 years ago #

    Run away. Switch hosts to a reputable one.

  12. slowhost
    Member
    Posted 2 years ago #

    Well stuck with them now, they are con artists, I was ringing them for a week with problems setting up my sites and they just palmed me off saying they couldnt understand what i was asking them!

    Then when i said right i want my money back and to cancel the hosting as i couldnt use it, they said its none refundable and said i can cancel but with no refund...joke...avoid at all costs...

    the very least they could do is sort this problem out..

    Any other ideas??

  13. esmi
    Forum Moderator
    Posted 2 years ago #

    Point them at this this thread and point out that they are now getting some very bad publicity.

  14. jimmerd
    Member
    Posted 2 years ago #

    Do you have cPanel access? Can you check there if PHP is in fact running? If it's PHP5?
    Is your site visible at all? Just admin pages are the problem?
    What's the URL?

  15. slowhost
    Member
    Posted 2 years ago #

    Yes i have cpanel access, Not sure how to check if its running or what version it is tho????

    The site is up and running http://www.exercisesupplies.co.uk My problem is i cannot edit any pages and none of the PHP is working.

    Thanks again for any help

  16. jimmerd
    Member
    Posted 2 years ago #

    Ah, well one problem is that the plugin exec-php is throwing errors:
    http://www.exercisesupplies.co.uk/tag/boxing-gloves/
    Warning: require() [function.require]: open_basedir restriction in effect. File(/home/fhlinux008/e/exercisesupplies.co.uk/user/htdocs/comparison/external.php) is not within the allowed path(s): (/home/exercise:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp) in /home/exercise/public_html/wp-content/plugins/exec-php/includes/runtime.php(42) : eval()'d code on line 2

    So the PHP that isn't working is what you're injecting on pages/posts?

    I don't know this plugin but it looks like the root of your problem is there. Try opening a ticket in the forums for the Exec-PHP plugin. The people who use it may know better than some of us.

    And it never hurts to re-upload the plugin fresh, to ensure it's uploaded properly.

  17. slowhost
    Member
    Posted 2 years ago #

    the reason its giving the error tho is because the files are in a different place now (as i`ve moved servers)

    All i want to do is change this part of text (/home/fhlinux008/e/exercisesupplies.co.uk/user/htdocs/comparison/external.php)

    as its not there anymore, its in a new location and needs updating. but i cant change it to fix the problem, as everytime i try to update in my wordpress panel, it sends me to the 501 page, then when i try again nothing has changed.

  18. jimmerd
    Member
    Posted 2 years ago #

    So you moved the database and it includes the path:
    /home/fhlinux008/e/exercisesupplies.co.uk/user/htdocs/comparison/external.php
    ?
    Which refers to the old host "fasthost"?

    So to fix, you could uninstall the plugin and ensure that all references to it are deleted from database. Then reinstall and it *should* rebuild the path with the new server info.
    Alternatively, talk to the host again (I know they've not been helpful but be patient) and ask them what the path should be. Then search the database and replace the path with the correct one.

  19. slowhost
    Member
    Posted 2 years ago #

    This is my problem i cannot change the code, wordpress wont let me!!!

    I have deleted the plugin, tried to add the code but wont let me, if i take out all php then the page will update as soon as i add php it wont let me update..

    thanks

  20. jimmerd
    Member
    Posted 2 years ago #

    Yep, I hear you.
    If this plugin did a clean uninstall, it'd be nice. It's unlikely.

    So I think you need to do a little database editing.
    Buried somewhere in the database is that path to your old Fasthost directory:
    /home/fhlinux008/e/exercisesupplies.co.uk/user/htdocs/comparison/external.php

    You need to find that little bastard and delete it.

    To do that, I'd suggest going into the CPanel and finding PHPmyAdmin in the database section. Navigate to your database and login.

    For some reason, my phpMyAdmin isn't working. I'm trying to replicate the problem so I can solve it. Will let you know if I succeed.

  21. jimmerd
    Member
    Posted 2 years ago #

    Can't find it. Giving up for the night.

    I think you should ask the plugin developer how to delete that path.

  22. turbo266
    Member
    Posted 2 years ago #

    I had a similar probem and chased it for a week, only to find out that I had my UTC and UTF setting wrong. I was supposed to be UTC-8 and UTF-8 under "setting" "reading"and I was UTC-7 "settings" General" and guess what? When i changed it to UTC-8 and UTF-8 like it should have been in the first place all my problems I was having saving things went away. I hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.