WordPress.org

Ready to get started?Download WordPress

Forums

Can't change network admin email (12 posts)

  1. handig
    Member
    Posted 2 years ago #

    Hi,
    Tried changing the network admin email adress to another email than the super admin email address. I went to network settngs and changed it but this didn't work. The messages still get the old email adress.

    I checked on the mysql table sitemeta and saw that the admin_email was changed. So I tried changing the super admin email aalso to the new other email adddress. In the wp table users I can see that it is changed to the new other email adress.

    But the messages like new blog created still have the old email adress.

    How is this possible and what can I do about it?

  2. Go back in the db and do a search on the whole db for the old email address. Find it and change it.

  3. sdgenxr
    Member
    Posted 2 years ago #

    I'm having a similar problem. My super admin has one email address and I would like to have the Network Admin email (under Network> Settings> Operational Settings> Network Admin Email) to be different. Is this possible?

    Even when I change the email address for either the "Network Admin Email" or my super admin email, new users don't get a confirmation email and existing users can't reset their password.

    Is there a setting somewhere I'm missing, or is there a code problem with in a network installation?

  4. The Network Admin Email has to be the email of the Network Admin (i.e. the Super Admin).

  5. sdgenxr
    Member
    Posted 2 years ago #

    Is there any way to override this setting so that the super admin has a different email address than network admin under network settings?

  6. Super Admin IS Network Admin.

    Same account. The email is part of the check. Why do you need it to go somewhere else?

  7. sdgenxr
    Member
    Posted 2 years ago #

    My web host does not allow me to send emails from WordPress unless they host my email as to verify that the from email is real and not spam. At this time I have my main domain set up with Google Apps and would like to keep it that way. What they have suggested is to use a subdomain that is hosted on their servers to send out emails from WordPress.

    I've tried to setup a smtp plugin to go around this but that didn't work either. Basically I would like to have a noreply@domain.com as the from address that WordPress uses to send out password resets and registration information and a separate email address for the super admin. Is this even possible?

  8. I would do this.

    Make a second account with the noreply email address, and make that a super admin. Then make that address the network admin email. See if that works.

  9. sdgenxr
    Member
    Posted 2 years ago #

    Looks like the email change took. Now I just need to make sure that WP can send emails through the subdomain address.

    What an ordeal!

  10. sdgenxr
    Member
    Posted 2 years ago #

    OK, still getting errors stating that my host has disabled the mail() function.

    How are others getting around the issue of having their network installs send emails when using Google Apps?

  11. That would be worthy it's own, separate, topic. :)

  12. sdgenxr
    Member
    Posted 2 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic