WordPress.org

Ready to get started?Download WordPress

Forums

Can't change language (9 posts)

  1. MiniatureZeus
    Member
    Posted 2 years ago #

    Hi,

    On my 3.2.1 installation of wordpress at blog.roadtripping.dk i can't change the language (both front and admin).

    I have uploaded the correct .po and .mo files in wp-content/languages and edited the wp-config also, but still the page is in english (I want to use a da_DK translation).

    The problem seems to be, that under Settings > General I cant find the drop-down menu where you can choose the default language. It is simply missing! The same is happening at the user-setting-page.

    Do anyone have a possible solution to this problem?

  2. cwcwilson
    Member
    Posted 2 years ago #

    I am in the same situation, can somebody help?
    I use the automatic installation, at the end of the installation it said the installation was completed without any problem.
    However, everything stays in english and I cannot find the button to change the language either.

  3. newbiwebi
    Member
    Posted 2 years ago #

    same for me...

  4. DariusLau
    Member
    Posted 2 years ago #

    Hi there!

    I had the same problem, I uploaded the proper .mo files and changed wp-config and the language would not update.

    What did the trick was to go to the Dashboard tab and the section Update

    Dashboard > Update

    where the system recognized that I had two different languages. I updated the core files in the desired language and presto!

    Let me know if it helps :)

  5. Make sure the install's language is set correctly in wp-config.php file, which should be located in your root folder.

    http://codex.wordpress.org/Editing_wp-config.php#Language_and_Language_Directory

    If you're seeing your site in English, then you will probably find this line of code:

    define('WPLANG', '');

    update it to this instead (for da_DK translation).

    define('WPLANG', 'da_DK');

  6. Makewebgr
    Member
    Posted 1 year ago #

    Same problem...

    WordPress 3.4.1.

    Greek language files wp-content/languages/: el.mo el.po admin-el.mo admin-el.po admin-network-el.mo admin-network-el.po

    wp-config: define('WPLANG', 'el');

    Tried to delete and re-upload el.mo files via ftp

    Tried to re-upload localised WordPress http://el.wordpress.org/wordpress-3.4.1-el.zip

    Both front-end and back-end still in English....

    This has never happened in my other wp sites.

    Dashboard reads:

    You have the latest version of WordPress. You do not need to update. However, if you want to re-install version 3.4.1–en_US, you can do so automatically or download the package and re-install manually:

    Download 3.4.1–en_US

    You are about to install WordPress 3.4.1 in English (US). There is a chance this update will break your translation. You may prefer to wait for the localized version to be released.

    when it should read "3.4.1–el".

    Any clues?

  7. thesos
    Member
    Posted 1 year ago #

    I just had some similar problem and solved it, so in case this could help I post here the way I did it.

    Open .po file with Poedit, check that your translations are correct.
    In Poedit, in File>Preferences>Editor>Behaviour (this is translated from french, so not sure if this is correct denomination), make sure that 'Compile automatically...' is checked.
    Save .po file, an .mo file is created.
    Upload .mo file that has been created this way, in wp-content/themes/[name of theme]/languages

    Hope it helps
    Cheers

  8. Makewebgr
    Member
    Posted 1 year ago #

    @thesos:

    I downloaded & installed Poedit from http://sourceforge.net/projects/poedit/

    Opened my el.po files, the translation is fine, checked the option you mentioned,saved the file and uploaded to server.

    Still English everywhere!

    Any other clues?

  9. Makewebgr
    Member
    Posted 1 year ago #

    Solved for me!

    The problem was due to me configuring wrong the settings of the qTranslate plugin.
    I needed to enter "el" at the "Locale" textbox.

    Now, languages work fine for me!

Topic Closed

This topic has been closed to new replies.

About this Topic