WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
[resolved] Can't authorize twitter account (39 posts)

  1. WolfSnap
    Member
    Posted 1 year ago #

    I've upgraded to the latest plugin version, created the consumer key on twitter's site, but, when I try to 'authorize twitter account' -- absolutely nothing happens.

    I've authorized the app on twitter, it shows as an app in my dashboard, and on the user account, etc.. But, I can't make it see that in the WP plugin.

    Ideas?

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    Did you fill in the consumer key (and consumer secret) in wp-admin -> "settings" -> "Twitter Widget" under "General Settings"?

  3. DDementia
    Member
    Posted 1 year ago #

    I have the same problem... the consumer and secret keys are filled in with the correct data, but when I click "Authorize New Account" it brings up the page wp-admin/options-general.php?page=twitterWidgetPro&action=authorize&_wpnonce=c11733bc61 but nothing seems to happen.

  4. WolfSnap
    Member
    Posted 1 year ago #

    Yes. Consumer key/secret are entered correctly.

  5. gkvwezep
    Member
    Posted 1 year ago #

    Same problem here. Update plugin, fill-in the correct consumer key/secret. After click at button 'authorize new account' I've got an error-page. The message is (in Dutch):

    Ho daar!
    De "request token" voor deze pagina is ongeldig. Deze kan mogelijk al gebruikt zijn of verlopen omdat deze te oud is. Ga alsjeblieft terug naar de site of applicatie die je hierheen stuurde en probeer het nog eens, het was waarschijnlijk gewoon een foutje.

    Translation:
    The "request token" for this page is invalid. This may be possible are already used or expired due to too old.

    So, what now?

  6. rogeridaho@rogeridaho.com
    Member
    Posted 1 year ago #

    sorry, have to say I am having the same problem as above users - enter the consumer key/secret and still the plug-in indicates (with a link) "you need to authorize your Twitter accounts", but when I click on the link, I go nowhere. Can't figure out the next step.

    Thanks for any assistance you can offer. btw, I am also willing to help with testing/feedback on the plug-in once it is operable. I am quite excited about using wordpress/twitter on my site.

    -roger

  7. caitplusate
    Member
    Posted 1 year ago #

    Same issue here! Hoping to get a resolution soon. I tried tweeting for help but have gotten no responses. When you filled in the info on the app page to get the key/secret, did you put your WP site for "website" (3rd field) and your Twitter account in the 4th field?

  8. Joff Crabtree
    Member
    Posted 1 year ago #

    Same here. Help!

  9. WolfSnap
    Member
    Posted 1 year ago #

    Plugin is totally not working. I've reset everything, tried again, set read/write, still nothing. It just simply won't work.

    Are you fixing this?

  10. CB-Denv
    Member
    Posted 1 year ago #

    I am having the same problem. After updating the Twitter Widget Pro plug-in, I was prompted to re-enter my consumer key and consumer secret, which I did. Then I clicked Update Options and then clicked Authorize New Accounts. That took me to the api.twitter page where I clicked Authorize App. It then tried to take me back to my blog admin page, but instead a blank page appears. When I go to my blog, Twitter feed still isn't showing up. Very frustrating.

  11. hervejodoin
    Member
    Posted 1 year ago #

    Having the same problem.

  12. CB-Denv
    Member
    Posted 1 year ago #

    Hard to believe no one is responding to these issues. I need my Twitter feed on my site, so I just switched to another plug-in.

  13. databell96
    Member
    Posted 1 year ago #

    Throwing my hat into the mix. Same thing occurring here.

  14. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    Hey guys, first of all I'd like to say that I WILL look into this. I just ran tests on every server I currently have access to, and was able to authorize accounts on every one of them. Until I can reproduce the error I can't fix it. Any additional information that you think it relevant would help.

    Also, to be clear and set reasonable expectations, it is NOT unreasonable that I haven't responded here in 7 hours. This is a completely free plugin that I create, maintain, and support for free. If you think it's "Hard to believe no one is responding to these issues" then please go ahead and find a different plugin.

  15. WolfSnap
    Member
    Posted 1 year ago #

    Thanks for responding Aaron. I'd be happy to get you whatever info you may need to help diagnose the problem.

    Feel free to email me directly at david (at) wolfsnap [dot} com (also, google talk at the same email). I can probably get you access to the site and you can poke around to solve the issue.

  16. dusares
    Member
    Posted 1 year ago #

    Hi Aaron, let me know what you need and I am happy to provide the information.

  17. CB-Denv
    Member
    Posted 1 year ago #

    I did switch to another plug-in and it worked immediately. So it's apparently not a WordPress or Twitter issue, if that helps.

  18. Billy
    Member
    Posted 1 year ago #

    The update broke for me, too. Consumer key and secret are fine, then I click authorize new account, it goes to Twitter, authorize, returning to site at /wp-admin/options-general.php?page=twitterWidgetPro&action=authorized&nonce=849b4de51106f7c4c216f46f4e0e8922&oauth_token=eCgagFNZkzs10bMJBMFTir4jrjLLiL6xOkBH7gmrY&oauth_verifier=l0qwTwcatddB6Qmnc6LPPfUDMwF8p10uPrO1ki78 and I get the following error:

    Fatal error: Cannot redeclare class OAuthUtil in /home/user/domain/wordpress/wp-content/plugins/simple-twitter-connect/OAuth.php on line 642

  19. BHRW
    Member
    Posted 1 year ago #

    For me the solution was mentioned in an earlier post:
    When preparing the application through twitter dev website:
    you need to set your own domain as the Callback url.
    After I did this, authorization went fine.

  20. Billy
    Member
    Posted 1 year ago #

    BOO-YA!!! Thanks, BHRW!

    I actually already had my domain set as callback in the Twitter app setup, but I didn't have a www. in front of it and that causes bad things to happen sometimes in my particular setup. After disabling Simple Twitter Connect to troubleshoot and making that small change, my Twitter Widget Pro is now working again. Yay!

  21. GabrielleTeare
    Member
    Posted 1 year ago #

    I have set own domain cannot authorise filled in all the keys need twitter feed

  22. marcreig
    Member
    Posted 1 year ago #

    Ok, let's see:

    - I'm developing on localhost. And it is NOT working on localhost.
    - I've created the APP on tweeter, wrote the real .org domains on fields, even callback URL, and saved everything.
    - Then I've authorized app on same twitter details page, and everything show fine now.

    http://i.imgur.com/W7naw0q.jpg

    - Then authorized localhost on @Anywhere domains like this:

    http://i.imgur.com/8Sml9L4.jpg

    as twitter doesn't like "localhost".

    So everything is fine, isn't it?

    - So everything OK on WP, on plugin settings page, but still having to authorize the app there, so when I press the button, I got this:

    http://i.imgur.com/ZsiAukQ.jpg

    Is this because localhost?

    Don't know what to do... :(

  23. andysbarnes
    Member
    Posted 1 year ago #

    Yep, had the same problem after I'd added in my consumer key and secret where clicking the 'authorize account' link didn't do anything. Adding my URL into the Callback URL box fixed it like a jiffy!

    Thanks BHRW for the fix and thanks Aaron for the update and (free for goodness sake!!) support :-)

    Donation for a beer heading over to you now..

  24. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    pixeldawg: If you could start a new thread (just copy your comment from above) I'd be happy to look into the conflict with Simple Twitter Connect.

    For everyone else: you definitely have to set the callback URL. The directions say:

    Fill in Name, Description, Website, and Callback URL (don't leave any blank) with anything you want

    Is there a way I could word that better to make it more clear? Twitter Widget Pro doesn't actually use the callback field (which is why it can be anything), but Twitter treats the application differently if it's filled in so we need it filled in.

    If your problem persists after setting the callback to your site URL (that seems most logical), please start a new support thread.

  25. hervejodoin
    Member
    Posted 1 year ago #

    Problem solved by setting the callback url.

    However, I had to reset my consumer key and consumer secret with the "Reset Key" function on dev.twitter.com and re-enter the new ones in WP for it to work.

  26. rogeridaho@rogeridaho.com
    Member
    Posted 1 year ago #

    This forum has been very useful in helping to resolve this problem. Thanks to everyone who posted and thanks to Aaron for developing the plug in and making it available to us,

    -roger

  27. ryancmiles
    Member
    Posted 1 year ago #

    I have a conflict with Tweet Blender.

    With Tweet Blender active I get this message: Fatal error: Cannot redeclare class OAuthUtil in /home/content/**/****/html/****/wp-content/plugins/twitter-widget-pro/lib/oauth-util.php on line 2

    When I deactivate Tweet Blender your plugin works so there must be a conflict with these two plugins.

    Any help would be appreciated.

  28. lgoddu
    Member
    Posted 1 year ago #

    Ok found the issue...

    If you set even a bogus callback. Then go to your site and click authorize (make sure you are logged into twitter) It will prompt you to authorize the application on your site. Then it should populate. Seems to be something with the twitter callback to the application.

    Hope that helps everyone!

  29. ryancmiles
    Member
    Posted 1 year ago #

    Looks like it was fixed. Thanks Aaron for being so quick with the update! Much appreciated.

  30. stateweshouldbein
    Member
    Posted 1 year ago #

    I had the same problem of disappearing widget after completing authorisation. The problem was that the account name had not been updated on the widget's settings or indeed in the Twitter Widget Pro section of Settings. Changing that and everything worked perfectly.

    Hope that also helps!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.