WordPress.org

Ready to get started?Download WordPress

Forums

Can't authenticate Google Analytics from Analytics360 plugin page (19 posts)

  1. thehealthyskeptic
    Member
    Posted 3 years ago #

    I'm trying to install the Analytics360 plugin which integrates Google Analytics and MailChimp tracking.

    I've been able to link the plugin with my MailChimp account, but when I attempt to link it with GA, I get this error message:

    The page you have requested cannot be displayed. Another site was requesting access to your Google Account, but sent a malformed request. Please contact the site that you were trying to use when you received this message to inform them of the error. A detailed error message follows:

    The site "http://mydomain.com" has not been registered.

    I've asked in the Google API forum, but they suggested I check with the developers. The developers don't support the plugin - in fact, they don't even list it on their site.

  2. shodezignz
    Member
    Posted 3 years ago #

    Same Problem here. Has anyone encountered this issue and resolved it or has a work around? Such as pluging in the api into the database or something?

  3. shodezignz
    Member
    Posted 3 years ago #

    Here is the answer in short you need to register your domain with Google. You can do it here
    https://www.google.com/accounts/ManageDomains

    • Type in domain and click add
    • click Manage yourdomain.com
    • agree to terms and services
    • type in http://yourdomain.com
    • type in description of site or title
    • click save
    • click return
    • Go back to Analytics360 and click authenticate

    Everything should work like butter now. I found the answer on at this site - rjmetrics I hope this helps.

  4. thehealthyskeptic
    Member
    Posted 3 years ago #

    Thanks for your reply. After I put my domain name in, I get a screen asking me to enter a "Target URL path prefix". What's that?

    Then it asks me for a certificate for my domain, with an upload button. Where do I get that?

  5. thehealthyskeptic
    Member
    Posted 3 years ago #

    Nevermind. I re-read your instructions, which were quite clear!

  6. G Morty Ortega
    Member
    Posted 3 years ago #

    I also had the same problem, although @shodezignz step-by-step process didn't help much. I still ended up at the screen asking me for Target URL path prefix.

    Poking around in the Google forums, I found the solution to this problem:

    Simply put "http://yourdomain.com/wp-admin" in the Target URL box and everything should work fine.

    Thank you all for your help!

  7. closetcoach
    Member
    Posted 2 years ago #

    This worked for me also.

  8. Vernon Fowler
    Member
    Posted 2 years ago #

    Thanks @shodezignz and @gabrielortega Your advice got me one step closer. Next I get an error as follows:

    Fatal error: Call to undefined method WP_Http::_getTransport() in /home/freetrap/public_html/cms/wp-content/plugins/analytics360/analytics360.php on line 640

    Is this one of those PHP4 calls and needs to be updated to PHP5 because WordPress 3.2 is no longer supporting PHP4?

  9. leroyschulz
    Member
    Posted 2 years ago #

    Thanks for these instructions, but I too can't get this to work.

    I've followed the instructions above (including entering "http://yourdomain.com/wp-admin" in the Target URL box) but when I, from the Analytics360 plugin page attempt to complete the authentication process by clicking the "grant access" button, I get this message:

    "Server error: The website encountered an error while retrieving http://www.domain.com/blog/wp-admin/options-general.php?a360_action=capture_ga_token&token=XXXXXXXXXXXXXXXXX. It may be down for maintenance or configured incorrectly.
    Here are some suggestions:
    Reload this web page later.
    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request."

    Any ideas?

  10. G Morty Ortega
    Member
    Posted 2 years ago #

    I've had it working recently with just the domain name, no "wp-admin" at all. Try that!

  11. leroyschulz
    Member
    Posted 2 years ago #

    My WP installation is in the /blog/ folder. So far I've tried:

    "http://yourdomain.com"
    "http://yourdomain.com/blog/"
    "http://yourdomain.com/blog/wp-admin/"

    All of those result in the same error message. Any other ideas?

    [L]

  12. ryanmaurodesign
    Member
    Posted 2 years ago #

    @leroyschulz

    add "www." in front of your address when entering your url for the value "Target URL path prefix:" in Google's site management. This worked for me.

  13. leroyschulz
    Member
    Posted 2 years ago #

    @ryanmaurodesign: Yep, I've already tried that. I still receive the same error message. Thanks for the idea though.

    [L]

  14. ryanmaurodesign
    Member
    Posted 2 years ago #

    @leroyschulz

    just to clarify what I did that made it work for me...
    • my domain name is: "www.yourdomain.com"
    • my blog actually lives in a subdirectory like yours, but "www.yourdomain.com" automatically points to that subdirectory
    • I already registered "www.yourdomain.com" with Google but Analytics360° wasn't working ( I got the same message as @thehealthyskeptic )
    • I had to additionally register "yourdomain.com" with Google and then list "www.yourdomain.com" as the "Target URL path prefix" of "yourdomain.com"
    • After that I was successful

    If this is obvious and what you've done already I apologize, if not hopefully it can help you and maybe others.

    note: I didn't put "http://yourdomain.com/wp-admin" in the Target URL box as @gabrielortega suggested yet I was still successful. Everything works for me except the site traffic graph, but that is a topic for another forum.

  15. leroyschulz
    Member
    Posted 2 years ago #

    @ryanmaurodesign

    Good news. I was able to authenticate just now. I did two things:

    1) I noticed that an update for the Analytics360 plugin was available so I installed it.
    2) I added the second entry to Google Accounts, as you suggested, so that I have this:
    • "http://www.yourdomain.com" and
    • "http://yourdomain.com"

    That worked. Thank you very much!

    [L]

  16. ryanmaurodesign
    Member
    Posted 2 years ago #

    @leroyschulz

    Awesome! Glad we figured it out.

  17. tropicofmom
    Member
    Posted 2 years ago #

    Woo hoo! The wp-admin for the Target URL path prefix is the missing piece of the puzzle I have been searching for! THANK YOU!!!

    Man, why does this stuff have to be so hard?

  18. cspowers
    Member
    Posted 2 years ago #

    Same problem here. I had the exact same message when I tried to use the import function to import a blog from blogger.com to a stand alone wordpress install.

    I am on 3.2.1

  19. Kenneth Jensen
    Member
    Posted 2 years ago #

    Wuuho, works for me now! Just followed the steps posted by shodezignz.

Topic Closed

This topic has been closed to new replies.

About this Topic