WordPress.org

Ready to get started?Download WordPress

Forums

Can't attach from with Media library (7 posts)

  1. Parneix
    Member
    Posted 3 years ago #

    Hi,

    I've uploaded a bunch of images via FTP. I've used the Add From Server plugin so they appear in my Media library.

    Now, I'd like to attach each of these images to the post they belong to (si I can make use of thumbnails for example).

    When I select an image (in the Media library) and click the "attach" link, there's pop-up window offering me to find a post or a page where I want to attach the image. I've tried to use keywords from the titles of existing post but here's the problem : each and every time time I hit the "serach" button... nothing happens. The box stays empty, nothing is displayed. Even though I'm using relevant search term.

    So I can't re-attach my images to the post they belong to and can't get thumbnails.

    Any idea?

    I appreciate it.

    P.

  2. Parneix
    Member
    Posted 3 years ago #

    The normal operation of this action is described in the WordPress Codex.

    P.

  3. Pierrick
    Member
    Posted 3 years ago #

    Hi,

    I have the same problem and was hoping to find a solution. Anyone who can help?

    Thanks

    P

  4. Jonas Grumby
    Member
    Posted 3 years ago #

    You are really doing this the hard way. Read this thread.

    http://wordpress.org/support/topic/image-uploader-now-not-working-please-help-ca?replies=2

  5. Pierrick
    Member
    Posted 3 years ago #

    Thank Jonas.

    I should have been made clearer that the issue I am having is that I cannot attach uploaded images to posts or pages. I am aware of the direct upload from a post or page and agree I would not do it via FTP!. Any ide then about the attach issue I am having?

    Thanks
    P

  6. Jonas Grumby
    Member
    Posted 3 years ago #

    Sorry I don't, but for future reference (for the user population at large), uploading via FTP, then using Add From Server, then associating the images with the correct page or post is a lot more work than using the built-in image uploader.

  7. Pierrick
    Member
    Posted 3 years ago #

    Thanks Jonas and agree on your last comment.

    I have atually just found out that the function I added in my functions.php file was causing the issue. I took the function from here - http://wpworks.wordpress.com/2011/02/01/display-wordpress-post-list-with-custom-size-thumbnails/

    Cheers

    P

Topic Closed

This topic has been closed to new replies.

About this Topic