WordPress.org

Ready to get started?Download WordPress

Forums

Can't Approve Comments! Please Help! (20 posts)

  1. xstatic
    Member
    Posted 5 years ago #

    When I try to appove pending comments from the edit-comments.php page, it changes the link from Approve to Unapprove as expected, but the comments do not appear in the article. Also, if I check the checkboxes and try to approve them in BULK it goes to a blank page.

    When I go back to the list of pending comments, all of the comments I previously approved are pending again.

    I upgraded to 2.7.1. via the automatic-wordpress-upgrade plug-in but this didn't fix the issue.

    Anybody have any ideas?

  2. greg2008
    Member
    Posted 5 years ago #

    Do you have any error.log files in your wordpress directory? Probably the main folder, but check the wrp-admin folder too.

  3. internetbusinesspath
    Member
    Posted 5 years ago #

    Hi,

    I am having the same problem and I have checked my error_log file to find any problems with no luck as well.

    At the moment the comments still come in, but when I try to bulk approve these comments, it takes me to a blank page. Or when I do press approve below each individual comment it shows it's approved dynamically, but when I refresh the screen the comment is still in pending.

    I have previously installed DISQUS and then uninstalled. This is when the problems started to occur. Any ideas or help would be appreciated.

    Thanks.

  4. matthewc
    Member
    Posted 5 years ago #

    I came across the problem and eventually (after a great deal of poking around) found the error was being caused by the debian package for wordpress, in combination with php4. Debian uses a separately packaged copy of phpmailer, which is called if you have your wordpress set to email you when new comments are posted. The current version of phpmailer (2.1-1) in debian is no longer php4-compatible. Unfortunately without hard-coding extra error output, this happens totally silently, as the phpmailer require_once gives a parse error.

    Basically there are two workarounds - either switch to using php5 (probably best if you can - php4's dead, baby, php4's dead), or replace the debian symlinked class-phpmailer.php and class-smtp.php files with ones from a vanilla wordpress package.

    If you're not using debian and php4, then I have no idea.

    Matthew

  5. Jennifer Martin
    Member
    Posted 5 years ago #

    Hi -

    I'm having a similar problem - I can't approve comments - I'm selecting the comment, choosing approve and hitting apply but they still do not appear on my website - am I doing something wrong? I'm not the hottest person on word press and I'd really appreciate some help,

    Many thanks in advance

    Jen

  6. williams94086
    Member
    Posted 5 years ago #

    I'm experiencing the same issue. Yesterday, all was fine.

    Today, when I receive a pending comment, I do not receive an email notification. My email account is working and I've rec'd other emails, just none that I normally receive when comments are left on my blog.

    Also, pending comments cannot be approved. When I click on 'approve' for a given comment, the status notes that it's approved. However, when the page is refreshed, it becomes pending once again. If I use the checkbox next to the pending comment and try a bulk action to approve, it takes me to a blank page. Comment remains pending.

    I'm using v.2.7.1. I am uncertain of which PHP version I am using (how do I know?) but my hosting provider appears to use 5.2.9, so I assume this is ok.

    Unfortunately, I'm traveling due to a family emergency and not able to research this fully. If there are any additional ideas, I would appreciate hearing them.

    Site in question: http://www.eatingoutloud.com

    Thanks!

    Allen

  7. gnorb
    Member
    Posted 5 years ago #

    I'll go ahead and add my voice to this. Same issues as above (no plugin involved, though). Can't approve comments. Thoughts? Anyone?

  8. smuffle89
    Member
    Posted 5 years ago #

    it looks as if matthewc gave a valid answer :/

  9. gnorb
    Member
    Posted 5 years ago #

    Using CentOS, but checked PHP version. It was still set to 4. Thanks!

  10. rupakg
    Member
    Posted 5 years ago #

    Hi All,
    I had the exact same problem. It seems that any plugin that is related to email can cause this issue. In my case, it was the "ShiftThis.net | Swift SMTP 1.0 Send email via SMTP (Compatible with GMAIL) By Marcus Vanstone" plugin. As soon as I deactivated the plugin, my comments started to get approved and I also started to receive emails when comments were posted.

    Hope it helps someone.

  11. M.Hassaan
    Member
    Posted 5 years ago #

    Guys, I have a fix, but its not a permanent one.
    Edit the comment in question, then select "Approved" from the status menu.. and its approved> Obviously its not a final solution, but its a temporary one!

  12. reybeez
    Member
    Posted 5 years ago #

    I just started getting this after my upgrade to 2.8. M.Hasaan's answer works though.

  13. bilalsarwari
    Member
    Posted 5 years ago #

    thank you hassan its work for me

  14. Whittakerj
    Member
    Posted 4 years ago #

    I had this same problem. I followed did like rpuakg said and uninstalled the gmail smtp plugin and it fixed me up.

    Hi All,
    I had the exact same problem. It seems that any plugin that is related to email can cause this issue. In my case, it was the "ShiftThis.net | Swift SMTP 1.0 Send email via SMTP (Compatible with GMAIL) By Marcus Vanstone" plugin. As soon as I deactivated the plugin, my comments started to get approved and I also started to receive emails when comments were posted.

    Hope it helps someone.

  15. happyches
    Member
    Posted 4 years ago #

    Same problem here for one of my blogs.. tried matthewc's suggestion of changing to PHP5, made no difference, uninstalled Ajax Comments but that made no difference, the only thing that has worked so far as clicking "edit" on the comment and approving that way, obviously that short term solution is not something I want to keep doing. Don't have any send email plugins.. hope to find the solution soon.

  16. Frank.Prendergast
    Member
    Posted 4 years ago #

    I'm having the same issue - have ensured I'm using PHP5 but the issue still remains.

    Approved comments revert to unapproved.
    Comments will approve through the edit comment page.

    Possibly related issue: When leaving a comment the page sometimes times out, but the comment goes through. Anyone else with the approving comments issue getting this as well?

  17. Frank.Prendergast
    Member
    Posted 4 years ago #

    I don't seem to have an issue with bulk approving, only approving via the dashboard.

    Also - I think matthewc is definitely onto something - if I turn off email notifications for comments the issues seem to go away. Anyone else confirm same?

    I'm currently having connectivity trouble, so can't get any further with this issue, but thought I'd update what I found so far anyway.

  18. Frank.Prendergast
    Member
    Posted 4 years ago #

    I *think* the issue has been resolved for me by matthewc's suggestions.

    I checked in my hosting control panel and turned off php4, forcing php5 to be used as the default.

    I then reuploaded class-phpmailer.php and class-smtp.php from the wp-includes folder.

    So far it appears as though the issues have disappeared.

  19. csw
    Member
    Posted 4 years ago #

    Hi,

    My bloggers encounter below error message when they tried to approve the comment via the notification email (click on the "Approve it" link) that sent by WordPress. But no error message appear when they approve the comments from the Administrator Panel.

    "Error 403
    We're sorry, but we could not fultill your request for /blogname/wp-admin/edit-comments.php?p=1433#comments on this server.
    You do not have permission to access this server. etc..."

    I'm currently using WordPressMU version 2.8.4a.

    Please help, and many thanks in advance.

  20. erichcervantez
    Member
    Posted 4 years ago #

    I have the same issue and it just suddenly appeared for me as well.

    I've had to access the underlying mysql database directly via phpMyAdmin to approve those comments.

Topic Closed

This topic has been closed to new replies.

About this Topic