WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] can't adjust width to extend 100% of page (10 posts)

  1. visual mechanics
    Member
    Posted 2 years ago #

    specifically the div for the entry date. is there another div preventing this?

    http://francescaromeo.com/blog

    i would like the 1px black line and the date to snap all the way to the right margin of the browser window like the thick black line in the 'top_navigation' div. would like the footer asset to behave the same as well.

    editing the #content div width:100%; causes conflict with the page layout.

    Thanks,
    Rob

  2. Yes, the Content CSS is doing this:

    #content {
    float: left;
    width: 1024px;
    margin: 75px 0px 20px 5px;
    }
  3. visual mechanics
    Member
    Posted 2 years ago #

    what additional attributes need to be included in the #content besides width:100%?

    currently the layout is shifted everything to the left.

    http://francescaromeo.com/blog

  4. alchymyth
    Forum Moderator
    Posted 2 years ago #

    this body div#wrapper{width:45em;} in this section in the head area is causing trouble:

    /* CSS inserted by theme options */
    body{font-family:'times new roman', times, serif;font-size:75%;}
    body div#wrapper{width:45em;}
    div#header,div..
    .......

    try to find and change these 'theme options' ...

    also, #wrapper has a 50px right padding; etc...

  5. visual mechanics
    Member
    Posted 2 years ago #

    the source for these just read "blog" is there a file i should be looking for?

  6. alchymyth
    Forum Moderator
    Posted 2 years ago #

    the source for these just read "blog" is there a file i should be looking for?

    i have no idea - i don't know the theme.

    can you post a download link for your theme?

    (there is only one quite old theme in the wordpress theme depository with the name 'simplr')

  7. visual mechanics
    Member
    Posted 2 years ago #

    that is the correct theme. it is old but I use it as it is pretty clean. I was able to set the 45em to 100% on the theme options dashboard.

  8. alchymyth
    Forum Moderator
    Posted 2 years ago #

    a few steps:

    #wrapper {
    	margin: 0px 50px 0px 0px;
    	text-align: left;
    	padding: 0px;
    }

    set the right padding to zero;

    #container {
      background-color: none;
      float: left;
      width: 0px;
    ...

    set width to 100%;

    #content{
      float: left;
      width: 1024px;
      margin: 75px 0px 20px 5px;
    ...

    set width to 100% and left margin to zero;

    now you should have your content sticking to the left and right edges (hopefully).

  9. visual mechanics
    Member
    Posted 2 years ago #

    that worked!! hi-5! it imposes a horizontal scroll bar no matter what the bowser windows width is adjusted to.is there a margin or padding that is causing this?

  10. alchymyth
    Forum Moderator
    Posted 2 years ago #

    the right padding in here has to be zero as well:

    #wrapper {
    	margin: 0px 0px 0px 0px;
    	text-align: left;
    	padding: 0px;
    	padding-right: 50px;
    }

    should be:

    #wrapper {
    	margin: 0px 0px 0px 0px;
    	text-align: left;
    	padding: 0px;
    }

    and in here, the 5px in the margins need to be set to 0px:

    #content{
      position:absolute;
      float: left;
      width: 100%;
      margin: 75px 0px 20px 5px; /* clockwise top, right, bottom, & left margins respectively */
      /* border: 1px solid #ff0000; */
    }

    -------
    if you want to have a few pixels margin from the text to the border, you need to set a padding-right:2px; in the style of .entry-date {}
    and possibly add new:
    .entry-content p {padding-right:2px;}

Topic Closed

This topic has been closed to new replies.

About this Topic