WordPress.org

Ready to get started?Download WordPress

Forums

Global Content Blocks
[resolved] Can't add or update (6 posts)

  1. tonicbox
    Member
    Posted 1 year ago #

    I'm using this plug-in on an older site, and yesterday we noticed that we couldn't update any GCBs or add new ones, despite the plug-in saying it had.

    The first thing I did was update the plug-in. No change.

    I then updated WordPress from 3.2.1 (I think) to the latest. No change.

    I then created a new site with a fresh install of WP and added the latest GCB. Works fine. Hmmm.

    On the problematic site, I've updated other plug-ins and that hasn't helped.

    Further to this, I exported the GCBs from the problematic site and imported them into the new site to check that they weren't the problem. They worked fine, but I noticed that their IDs had completely changed. For example, ID 459 had become 259. This would be a real problem had I have removed them from the problematic site and re-imported them.

    http://wordpress.org/extend/plugins/global-content-blocks/

  2. benz1
    Member
    Plugin Author

    Posted 1 year ago #

    We are unable to replicate this issue but my developer is trying to find the problem. Will release an update when resolved.

  3. tonicbox
    Member
    Posted 1 year ago #

    Thanks for looking into it. I can give you access to the site so you can see for yourself if that helps - maybe you can see something obvious from the output in Firebug or something similar?

  4. benz1
    Member
    Plugin Author

    Posted 1 year ago #

    Apologies for the delay. My developer thinks the issue only occured when updating from an old version and has simplified the code. He thinks it should resolve the issue but would be good if you could test first before I update on the repository.

    You can download the updated version from benz1.com/temp/global-content-blocks-1-5-7-beta.zip and replace your existing version. Can you please let me know if this resolves the issue for you?

    Thanks.

  5. tonicbox
    Member
    Posted 1 year ago #

    Thanks! This has resolved the problem.

    I have been able to add new blocks and update existing ones.

    Many thanks!

  6. benz1
    Member
    Plugin Author

    Posted 1 year ago #

    Cool, thanks for testing. I'll update it on the repository later today.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.