WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't add new users - HELP! (40 posts)

  1. robbarron1
    Member
    Posted 2 years ago #

    Hi.

    I'm a bit of WordPress noob so please bear with me...

    I've set up and self-hosted my site http://transenduro.co.uk/transpyrenduro/

    It's up and running and I'm able to create posts and pages absolutely fine. Now I want to add a new user so my friend can also contribute to the site. This is where my problem lies – every time I attempt to add him, I get "the requested user does not exist". My only option is to add the new user as an existing user on the network and I'm sure this is where the problem is. I don't have the option on my dashboard to add a new user and the associated form, just the option to add an existing user...which doesn't seem to work. In fact, having looked through several support threads, there are several options that appear to be absent from my dashboard.

    I don't (as far as I know) have any plugins running, I think it's the standard installation of Twenty Eleven. I had problems getting the iPhone WP app to talk to the site and it turned out to be my host (NamesCo) blocking certain php files so I'm wondering if that's it?

    I've only got one WP site running on the domain, but I have enabled multisite just to be on the safe side. In fact when I looked at the php it was already enabled.

    I started following the Create a Network instructions, and only got as far as completing step 2! After that, step 3 doesn't seem to work as I can't see Network Setup in my Dashboard.

    Confused!

  2. My only option is to add the new user as an existing user on the network and I'm sure this is where the problem is.

    No that's where the SOLUTION is :)

    Multisite - Add users to the network. THEN add them per-site.

    You were doing it right.

  3. robbarron1
    Member
    Posted 2 years ago #

    ... I'm sure this is where the problem is. I don't have the option on my dashboard to add a new user and the associated form, just the option to add an existing user...which doesn't seem to work. In fact, having looked through several support threads, there are several options that appear to be absent from my dashboard.

    Despite having enabled Multisite in the php, the Network options haven't been enabled (ie they've not appeared) in my dashboard so I can't add a new user.

  4. You don't see http://codex.wordpress.org/images/7/7c/tools-network.png

    Did you put define('WP_ALLOW_MULTISITE', true); in your wp-config.php, ABOVE the 'stop editing here' line?

  5. robbarron1
    Member
    Posted 2 years ago #

    Yup, done that...and just checked again to make sure.

    I've only got one WP site running on the domain, but I have enabled multisite just to be on the safe side. In fact when I looked at the php it was already enabled.

    I started following the Create a Network instructions, and only got as far as completing step 2! After that, step 3 doesn't seem to work as I can't see Network Setup in my Dashboard.

    Which is why I'm wondering if my host is blocking something...

  6. What do you mean by 'In fact when I looked at the php it was already enabled.' ?

    And who's your host?

  7. robbarron1
    Member
    Posted 2 years ago #

    What do you mean by 'In fact when I looked at the php it was already enabled.' ?

    And who's your host?

    I mean that when I opened up the php to insert define('WP_ALLOW_MULTISITE', true); it was already there, ie already "true".

    Host is NamesCo

  8. robbarron1
    Member
    Posted 2 years ago #

    You don't see http://codex.wordpress.org/images/7/7c/tools-network.png

    ...and no, I don't get those tools at all

  9. That's ... odd. It shouldn't be there before you start.

    Go look at your database. Does it have wp_sites and wp_sitesmeta tables?

  10. robbarron1
    Member
    Posted 2 years ago #

    Look at my database? Hmmmmmm... I refer you to my initial "I'm a WP noob" comment. I'm afraid you've lost me there. Where would I find that? :o/

    Thanks for your help thus far by the way...

  11. Welcome to running a Multisite.

    Two things you MUST get familiar with if you have a prayer of maintaining it are FTP and at the very least, LOOKING at your DB.

    See if your host's control panel has phpMyAdmin. If not, check their knowledge base for SQL tools.

  12. robbarron1
    Member
    Posted 2 years ago #

    FTP - no probs, it's part of my daily bread.

    PHP and SQL etc not so much, not at all in fact....but I'll take a look!

    <some time later> Ok yes, I've looked at the mySQL databases menu via my hosts Control Panel. Very limited functionality on there but I have switched a few options on that were previously off, such as remote access.

    I've also located the relevant file via my http://FTP...I think.

  13. Okay, go back to what I asked.

    Go look at your database. Does it have wp_sites and wp_sitesmeta tables?

    Are they there? If not, check that the ID you have listed for SQL in wp-config.php has access to create tables.

  14. robbarron1
    Member
    Posted 2 years ago #

    Hmmmm ok, don't seem to have those anywhere.

    What I have found however in /wp-admin/network/sites.php is this which appears to say multisite is NOT enabled:

    <?php
    /**
     * Multisite sites administration panel.
     *
     * @package WordPress
     * @subpackage Multisite
     * @since 3.0.0
     */
    
    /** Load WordPress Administration Bootstrap */
    require_once( './admin.php' );
    
    if ( ! is_multisite() )
    	wp_die( __( 'Multisite support is not enabled.' ) );
    
    if ( ! current_user_can( 'manage_sites' ) )
    	wp_die( __( 'You do not have permission to access this page.' ) );
    
    $wp_list_table = _get_list_table('WP_MS_Sites_List_Table');
    $pagenum = $wp_list_table->get_pagenum();
    
    $title = __( 'Sites' );
    $parent_file = 'sites.php';
  15. LEAVE THAT FILE ALONE. It's core, don't TOUCH IT unless you are a WordPress expert. Back away from that file please.

    Okay, if the tables are MISSING that's the issue.

    Delete the define('WP_ALLOW_MULTISITE', true); line from wp-config.

    Log out of WP.

    Log back in.

    Add the line BACK in.

    Log out and back in again.

    Do the tables get created? If NOT, ask your host.

  16. robbarron1
    Member
    Posted 2 years ago #

    OK, done that.

    No tables appear to have appeared. I think I may have broken it!

    Looking at the WP app on my iPhone, I now get the old "Blog returned invalid data" and I am unable to post/edit etc

    Back on the Mac, when I try to logout of my dashboard (or try to login from a different browser) I now get a screen full of errors:

    Warning: Cannot modify header information - headers already sent by (output started at /content/StartupHost/t/r/transenduro.co.uk/web/transpyrenduro/wp-config.php:1) in /content/StartupHost/t/r/transenduro.co.uk/web/transpyrenduro/wp-login.php on line 349

  17. robbarron1
    Member
    Posted 2 years ago #

    Oh actually...I did manage to post off my iPhone, although it still shows an error.

  18. robbarron1
    Member
    Posted 2 years ago #

    Logged out...now it won't let me log back in...

    Warning: Cannot modify header information - headers already sent by (output started at /content/StartupHost/t/r/transenduro.co.uk/web/transpyrenduro/wp-config.php:1) in /content/StartupHost/t/r/transenduro.co.uk/web/transpyrenduro/wp-includes/pluggable.php on line 866

    Oh deary me :o/

  19. robbarron1
    Member
    Posted 2 years ago #

    Hmmm ok, with a spot of trawling I seem to have made those errors go away, however my initial problem remains.

    One question - do I actually need to enable MultiSite? I don't want to add anymore sites (not at this stage anyway), I simply want to add another user as a second Admin or even just contributor on the one existing site I already have.

    Seems like I'm having to go all around the houses to achieve something that should be very simple :o/

  20. Axel13
    Member
    Posted 2 years ago #

    It seems you started the setup of a multisite, but didn't entirely finish it. Once you manage to finish the setup, you'll be able to add users through a new admin panel that will become available.

    If you don't need multisite, you can turn back to the regular WP, which is quite a bit easier to work with, but if you plan on making a new blog later on, you could better find out what's wrong now.

    To revert back to a regular WP, you can change the wp-config.php and the .htaccess back to the original state and I think you can delete these tables from your database (myPHPadmin):
    • wp_blogs
    • wp_blog_versions
    • wp_registration_log
    • wp_signups
    • wp_site
    • wp_sitemeta

  21. Axel13
    Member
    Posted 2 years ago #

    Btw, I think multisite always needs to be installed with WP in the root, if you installed it in the folder .../transpyrenduro/, this could cause the problem (not entirely certain). In your case I'd think it would be a better practice to turn the main site in a WP-site with your blog and the other subsites the current site refers to as subsites.

  22. You don't HAVE to install in root.

    Since his URL is http://transenduro.co.uk/transpyrenduro/ that's fine :) All his sites will start with that URL as well.

    One question - do I actually need to enable MultiSite? I don't want to add anymore sites (not at this stage anyway), I simply want to add another user as a second Admin or even just contributor on the one existing site I already have.

    No. You don't need Multisite at all for that. Just add a new user.

  23. robbarron1
    Member
    Posted 2 years ago #

    Ok, so I really am going round the houses!

    Right, the reason I've posted in Multisite help is that I was directed to do so after originally posting in general help <sigh>

    So anyway, that aside, my (by all accounts very basic) problem remains - I cannot add a new user!

    My ONLY option when I go to do this is to "add existing user" and as there are none other than me that doesn't work.

    Soooooo.... Back to my original question, why can't I add a new user?!

  24. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Warning: Cannot modify header information

    You now appear to have an issue in your wp-config.php file. See Solving "headers already sent" warnings.

    I was directed to do so after originally posting in general help

    That was purely because you said that you were using Multisite.

    why can't I add a new user?

    At the risk of muddying the waters, are you sure that you are logged in with full admin privileges?

  25. I started following the Create a Network instructions, and only got as far as completing step 2! After that, step 3 doesn't seem to work as I can't see Network Setup in my Dashboard.

    *head desk* I swear I know this one...

    Okay

    1) Do you WANT to use Multisite?

    2) If so, where in your wp-config.php is the line define('WP_ALLOW_MULTISITE', true);

    What's above and below it?

  26. robbarron1
    Member
    Posted 2 years ago #

    Right, let's start again before we all throw ourselves off a tall building...

    I want to add my friend as a new user to my WP site http://transenduro.co.uk/transpyrenduro/

    However, from my dashboard, the only option available to me is to add an existing user.
    I do not have the add new user option. As I am the only existing user thats not much good to me.

    That, in a nutshell, is my problem.

    Anyone able to help? Please?!

  27. Do you want Multisite though? Yes or no?

    Cause we can either spend time trying to FIX multisite, or uninstall it. Which way do we go? Up to you :)

  28. robbarron1
    Member
    Posted 2 years ago #

    In a word No. I dont think so.

    Literally all I want to do is figure out how I can add another user to my one existing site.

    So, if I can do that without Multisite then great. The simpler the better. :-)

  29. robbarron1
    Member
    Posted 2 years ago #

    http://www.transenduro.co.uk/pics/addnewuser.jpg

    No option to add NEW user...just existing.

  30. That;s becuase you've got Multisite.

    Read this: http://wpmututorials.com/how-to/how-to-disable-multisite/

    Do that. Multisite goes away.

Topic Closed

This topic has been closed to new replies.

About this Topic