WordPress.org

Ready to get started?Download WordPress

Forums

Can't add new items to appearance menu (2 posts)

  1. bakedbean
    Member
    Posted 1 year ago #

    Hello all,

    I have a particularily frustrating problem at the moment. Having set up a new site for a client with everything running normally a problem with adding menu items to the appearance menu has suddenly occured. When you drag an item over to the custom menu the item disappearsa when you refresh the page. When adding the item i get this warming: 'Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'add_new_post_type' was given in /var/www/vhosts/in-beta2.co.uk/subdomains/nb/httpdocs/wp-includes/plugin.php on line 403'.

    I supected it may be a plugin so I disabled all plugins and tried again put the problem persists. I have read various postings regarding this and many of them seem to relate to the number or menu items being too large. I'm pretty sure this can't be the issues as there aren't that many items on my menu. Has anyone got any ideas? The client is getting very impatient!

    Thanks

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.