WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Can't Add Media to Page/Product with WordPress 3.5 (42 posts)

  1. jennifer104
    Member
    Posted 1 year ago #

    Hello

    I am having issues similar to the ones others have posted with uploading media to my pages. I followed the instructions in a few other posts but nothing has worked. I've done the following so far:
    - Deactivated all plugins
    - Refreshed my plugin folder
    - Reinstalled WordPress manually
    - Tried the Twenty Twelve theme-- still does not work.

    Nothing is working. Please help. I'm in the process of setting up my site and this has been hindering my progress.

  2. It is either a...

    1. Plugin issue
    2. Theme issue
    3. Hosting issue

    There is simply nothing else it could be.

    So... here are the first steps...

    1. Deactivate ALL of your plugins. Yes.. ALL of them.
    2. Manually empty your browser cache.

    These first two steps are VERY important.

    Now, go back and try it again and see what happens.

  3. jennifer104
    Member
    Posted 1 year ago #

    Hi Josh

    As I mentioned in my original post, I already have deactivated ALL of my plugins. Nothing is currently active.

    I didn't mention in my post, but I also deleted my cache as well and also tried to run from IE (i use chrome.) That also didn't work.

    This is so frustrating!I'm at my wits-end. I have been trying to fix for the past 4 hours and have followed every instruction posted.

  4. Who is your hosting provider?

  5. jennifer104
    Member
    Posted 1 year ago #

    Dreamhost

  6. What happens? Are you receiving any errors or warnings? Does the window load initially? At what point exactly do problems occur?

  7. jennifer104
    Member
    Posted 1 year ago #

    No errors. The window to add media just doesn't pop up. I'm able to add media directly to the media library-- just nothing happens when I click add media in a page or post.

    If I hover over the add media button-- in the bottom of my browser, I can see that it's linked to: "www.swappsee.com/wp-admin/post-new.php#"
    But when I click on it, I get nothing.

  8. stephensutton
    Member
    Posted 1 year ago #

    I am having exactly the same and have tried the same fixes but nothing is working. Any one found a solution yet??

  9. danromanchik
    Member
    Posted 1 year ago #

    If you ask me, this is really a v3.5 problem. I just upgraded wa2hom.org to v3.5, am using the Twenty Twelve theme, and have no plugins activated, and I still can't assign a featured image or insert images into posts.

    I tried adding the statement define('CONCATENATE_SCRIPTS', false ); into wp-config.php, but that only partially fixed the problem.

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    @stephensutton &@danromanchik: It is impolite to interrupt another poster's ongoing thread with a question of your own. It causes significant problems for the forum's volunteers and prevents us from being able to track issues by topic. Please post your own topic.

  11. danromanchik
    Member
    Posted 1 year ago #

    Sorry, but I wasn't asking a question of my own. I was trying to add some data to the discussion.

  12. stephensutton
    Member
    Posted 1 year ago #

    I dont think these were new questions, just adding to your one. But very sorry anyhow.

  13. jennifer104
    Member
    Posted 1 year ago #

    Esmi-- can you please help? I don't know what else to do here. I can you login credentials if that will help.

  14. esmi
    Forum Moderator
    Posted 1 year ago #

  15. jennifer104
    Member
    Posted 1 year ago #

    Yep! I've done everything on this list. I don't know where to go from here.

    -flushing any caching plugins you might be running, as well as server and/or browser caches.
    -deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin (read http://bit.ly/UhpkLl if you need help). Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old (read http://bit.ly/WMrMM5 for more information on mu-plugins)
    -switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can't log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.
    -manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.5 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first: http://bit.ly/RbU5qG

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    Did you reset the plugins folder using Phpmyadmin?

  17. jennifer104
    Member
    Posted 1 year ago #

    I reset it using my FTP login with Filezilla.

    I followed these instructions:
    Via FTP or your host's file manager, navigate to the wp-contents folder (directory)
    Via FTP or your host's file manager, rename the folder "plugins" to "plugins.hold"
    Login to your WordPress administration menus (/wp-admin)
    Via FTP or your host's file manager, rename "plugins.hold" back to "plugins"

  18. esmi
    Forum Moderator
    Posted 1 year ago #

    Try the Phpmyadmin method. It is needed in some situations.

  19. jennifer104
    Member
    Posted 1 year ago #

    I just went in to make the adjustment using PHPmyadmin and the Option value for active plugins was already "a:0:{}" as described in the instructions.

    Any other suggestions? Something else must be going on. I've literally done everything listed.

  20. esmi
    Forum Moderator
    Posted 1 year ago #

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

  21. jennifer104
    Member
    Posted 1 year ago #

    I get this error now: Parse error: syntax error, unexpected ',' in /home/swappsee/swappsee.com/wp-config.php on line 99

    Should I add the code above the required_once line or in front of it?

  22. jennifer104
    Member
    Posted 1 year ago #

    Wait I messed that one up. I missed the "define." Trying again.

  23. jennifer104
    Member
    Posted 1 year ago #

    That worked!!

  24. jennifer104
    Member
    Posted 1 year ago #

    Thanks SO much! I was pulling my hair out. Do I need to leave that code in for now? Can I start to reactivate my plugins as well or could there still be an issue with the plugins?

  25. esmi
    Forum Moderator
    Posted 1 year ago #

    Above.

  26. esmi
    Forum Moderator
    Posted 1 year ago #

    Can I start to reactivate my plugins as well or could there still be an issue with the plugins?

    I'd suggest re-activating them one by one - checking the site carefully after each re-activation.

  27. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    jennifer104, the problem is Google Page Speed. We're working for a fix here at DH, and we have a couple options that are semi-perfect. Until then, though, we recommend you either leave that line in your wp-config.php or turn off pagespeed.

    I'm really glad you found the answer here :) If you need any help from our DreamHost gurus, give a shout. We're here for you too!

  28. nobledenim
    Member
    Posted 1 year ago #

    Awesome!! Thanks so much esmi. I had the exact same issue and it couldn't have come at a worse time. I've been trying to figure out a fix for a couple days... and likewise did everything I could find (I just found this post thankfully).
    I'm also on Dreamhost.

    Mike E. - can you keep us posted on if you all fix the issue for dreamhost customers? And if we should ever remove that added piece of code or what else you'd recommend? Yall are always so helpful.

    Thanks Everyone!

  29. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    nobledenim, I will do my best to hit back all the threads I've seen about this. :)

    You're welcome, and thank you for being patient and understanding!

  30. BTCoombs
    Member
    Posted 1 year ago #

    I also just uploaded W/P 3.5 and cannot seem to upload pictures to my library. My custom them is also missing the pictures with only empty boxes where they should be. I see some of you have figured out how to get around this issue for the moment, but could someone please explain it in laymen terms. I can log onto my Dreahhost PHP Admin but from that point have no idea what I'm looking at or how to proceed.
    http://www.cvinspectionsolutions.com

    Thanks,

Topic Closed

This topic has been closed to new replies.

About this Topic