WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't add images to posts or edit existing posts with images (10 posts)

  1. modernape
    Member
    Posted 1 year ago #

    Since 3.5.1 I can't edit existing posts if they contain images, nor can I add images to new posts. When I click on 'Update' after editing a post, my browser gives me an error message that the web-page is unavailable "because the server where this page is located isn't responding". If the post has no images, then the update is saved.

    Similarly, the Media Library displays empty, despite images having been uploaded into the correct folder (wp-content/uploads), and when I try to upload new images with the multi-file uploader, I just get the message "failed to upload due to an error -
    The uploaded file could not be moved to /.../wp-content/uploads."
    If I use the browser file uploader, I get this:
    "Error saving media attachment".

    I have gone through the troubleshooting master list, deleted all plugins, switched to the latest version of the twenty eleven theme, tried three different browsers, re-installed 3.5.1 again, pasted define(‘CONCATENATE_SCRIPTS’, false ); into wp-config.php; tried inserting images from a URL rather than the library; all to no avail.

    Any ideas what to try next?

  2. wotnow
    Member
    Posted 1 year ago #

    Hi I am no expert but have you tried re-saving your permalinks, dont change anything just re-save.

    Long shot but you never know! Also have you looked in your upload folder via FTP? Are there images in there?

  3. modernape
    Member
    Posted 1 year ago #

    Yes, the images are definitely there in the uploads folder.

    What makes you think this has anything to do with permalinks?

  4. wotnow
    Member
    Posted 1 year ago #

    web page unavailable .. you have tried the obvious with permissions?

  5. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Have you talked to your hosts? WordPress needs a temp folder on the server. Maybe something has changed on their end.

  6. modernape
    Member
    Posted 1 year ago #

    Where is the wordpress temp folder usually located?

  7. Zara Walsh
    Member
    Posted 1 year ago #

    When you say posts with images. Are the images featured images or in the content or both?

    Trying to establish if one or the other causes the issue. It's a strange one.

    Did you disable all plugins, especially gallery/image related ones that may hook into actions you take on Edit Post screen?

  8. modernape
    Member
    Posted 1 year ago #

    Or, more importantly perhaps, how can I diagnose if that is in fact the problem?

  9. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    It is set by your host. You will need to contact your host and ask them if they specified a temporary directory (e.g. upload_tmp_dir in php.ini)

  10. modernape
    Member
    Posted 1 year ago #

    Damn it, it was a mis-configuration by the server host of their 'intrusion prevention apps'. They've now resolved it, it was nothing to do with my install (GRRRRR!)

Topic Closed

This topic has been closed to new replies.

About this Topic