WordPress.org

Ready to get started?Download WordPress

Forums

User Submitted Posts
[resolved] Can't add anchor (href) to external site (11 posts)

  1. 1BJK903
    Member
    Posted 1 year ago #

    Hi all,

    Does anyone know how to send an external link via user submitted posts? When I enter a href in the textarea, it just becomes plain text and not an anchor with a link.

    How can I make this work?

    http://wordpress.org/extend/plugins/user-submitted-posts/

  2. Jeff Starr
    Member
    Plugin Author

    Posted 11 months ago #

    Hello, I just tested this and was able to include both of the following via the textarea:

    <a href="http://example.com/">inside anchor</a>

    http://example.com/

    When viewing the post, the link is displayed as a link and the URL is auto-converted to a link via WordPress.

    If something else is happening in your case it could be that something else (eg, another plugin) is interfering..

  3. 1BJK903
    Member
    Posted 11 months ago #

    Hmm, the first one works for me, but your second link stays a blank plain text. Damn it, I have to check all of the plugins then. Thanks for the response.

  4. Jeff Starr
    Member
    Plugin Author

    Posted 11 months ago #

    1BJK903, nope - you are correct.. I just double checked and only the first one is displayed as a link.. the URL is not auto-formatted.. I will try to fix for next update :)

  5. 1BJK903
    Member
    Posted 11 months ago #

    Ah, thanks man! When will be the next update? In month, weeks?

  6. Jeff Starr
    Member
    Plugin Author

    Posted 11 months ago #

    days ;)

  7. 1BJK903
    Member
    Posted 11 months ago #

    Oh, great man. Thanks!

  8. Jeff Starr
    Member
    Plugin Author

    Posted 11 months ago #

    Hey it looks like WordPress doesn't auto-format URLs in post content.. I've been trying but no go for default WP install. Let me know if you discover otherwise and I'll take another look. Sorry for the confusion :P

  9. 1BJK903
    Member
    Posted 11 months ago #

    Hmm, too bad. That's very weird though, because it is working on comments... Damn this shit.

    Anyway, thanks mate!

  10. Jeff Starr
    Member
    Plugin Author

    Posted 11 months ago #

    Yes, comments should auto-format URLs by default. You may want to check for a plugin though that can do it.. makes life easier :)

  11. 1BJK903
    Member
    Posted 11 months ago #

    Yes, that is the case indeed, but too bad you can't do it for the posts. That is essential to me. Anyhow, I will see what I can do. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic