WordPress.org

Ready to get started?Download WordPress

Forums

can't add a comment (19 posts)

  1. salve_cc
    Member
    Posted 6 years ago #

    just published a new website salvethought.com
    my problem is i want anybody to comment even if they are not registered to my website...i'm using wordpress 2.3.3, help pls. Do i need to edit the comment.php?

  2. windrago
    Member
    Posted 6 years ago #

    I have the same issue. A lot of other users have the same problem. I have looked everywhere on these forums, but no one has provided an answer!

  3. moshu
    Member
    Posted 6 years ago #

    No, you don't have the same issue. It is never the same: it's a different server, a different theme and so on.
    Always describe in details WHAT is your problem and question.
    Did you check your moderation queue?

  4. moshu
    Member
    Posted 6 years ago #

    salve,
    does your issue persist if you switch to another theme, like the default or classic?
    Seemingly your theme doesn't have the call for the comments template.

  5. salve_cc
    Member
    Posted 6 years ago #

    i used different themes...and it's all the same...what i want is everyone who wants to comment can comment on my blog without having to register ...

  6. moshu
    Member
    Posted 6 years ago #

    Registering or not that up to you: that depends on your settings. (Just read your own admin panel)
    I didn't ask that.
    Can you leave it for a while with the classic or default theme?

  7. eracc
    Member
    Posted 6 years ago #

    I came here with the same problem. WordPress 2.3.3 users cannot post comments. FYI, my administration user (me!) cannot post comments either. I have tried the default WordPress theme as well as other themes. I was hoping this thread had a solution but am disappointed to find it does not.

    I thought perhaps the host provided upgrade to 2.3.3 from the older WordPress was the problem. So I completely wiped out my /blog/ directory on the host and recreated it from a fresh WordPress 2.3.3 download. No joy. I checked the MySQL database with the host provided phpMyAdmin and all appears to be in order.

  8. boober
    Member
    Posted 6 years ago #

    do you have comments turned on in your admin? if they were off, or not allowed, even if you turn them on, that setting only activates them on post you make from that point on. for existing posts you need to edit them and check the box to allow comments in the 'discussion' box on that posts edit page.

  9. eracc
    Member
    Posted 6 years ago #

    Comments have always been enabled on this blog.

    x Allow people to post comments on the article

    Plus the articles on which users cannot post comments have the [Allow Comments] box checked. Before I ran the update to get 2.3.3 users could post comments as there are comments from before the update. See the blog blog.eracc.com to see that comments did work at one point.

  10. boober
    Member
    Posted 6 years ago #

    it says
    You must login to post a comment.

    you seem to have it set to only allow logged in users to comment.

  11. eracc
    Member
    Posted 6 years ago #

    Yes, that is correct. Makes no difference if they login or not, they can never post a comment. My administration user is logged in right now. Cannot comment on any of the articles.

    Edit: I will not allow unapproved, unregistered users to comment on my technical blog.

  12. boober
    Member
    Posted 6 years ago #

    just saying no one can comment doesnt really help us help you. we need more info. do you get an error? does the comment box not appear at all? do comments show up in a queue in your admin? etc.

  13. eracc
    Member
    Posted 6 years ago #

    There is never a comment box at all.

  14. eracc
    Member
    Posted 6 years ago #

    If I use a test user to "login" to post a comment that user sees the dashboard when logging in. Then if the user clicks the "(View site ยป)" link they go to the blog and it is as if they never logged in. They never get a comment box.

    Edit: I can create a test user called boober and let you try it. :)

  15. boober
    Member
    Posted 6 years ago #

    that may help

  16. eracc
    Member
    Posted 6 years ago #

    AH HA! I figured it out. :)

    The blog is a subdirectory/subdomain off my main web site http://www.eracc.com. In the General Options the "WordPress address (URL):" was pointing to http://www.eracc.com/blog but the "Blog address (URL):" was pointing to http://blog.eracc.com and this apparently caused a conflict. I set them both to http://blog.eracc.com and the problem is resolved.

    Oddly enough that has not been changed since the day I first installed WordPress and comments were working in the past. Oh well, at least I figured it out. :)

  17. eracc
    Member
    Posted 6 years ago #

    Bah! Now I am getting "Sorry, you can only post a new comment once every 15 seconds." and I have waited 2 minutes. Where do I go fix that?

  18. eracc
    Member
    Posted 6 years ago #

    Frap! Now my test user gets the comment box but when trying to post a comment nothing happens. (Well a small rectangle appears to the left of the [Submit] button but no comment is added.)

    Edit: I have no more time to work on this today. Will check back on this thread tomorrow.

  19. eracc
    Member
    Posted 6 years ago #

    I'm back, still have the same problem, "Sorry, you can only post a new comment once every 15 seconds.", no matter how long I wait.

    Well, actually, I can post one comment from one user per day then it quits working until the next day. I am at a loss where to go from here and searching for that error message has gotten me no further in resolving this. Anyone with more experience with the "guts" of WordPress please help.

Topic Closed

This topic has been closed to new replies.

About this Topic