WordPress.org

Ready to get started?Download WordPress

Forums

Stop! You Never Have To Fight Comment Spam Again
[resolved] Can't activate spamhammer series 1 (6 posts)

  1. cmurphy060960
    Member
    Posted 1 year ago #

    Installed spammers suck! v 1.7.2
    did manual install and auto install - files/folders in right place for each install. When activating get message...

    "Plugin could not be activated because it triggered a fatal error."

    "Parse error: syntax error, unexpected T_STATIC in /home/ch.../public_html/wp/wp-content/plugins/spammers-suck/includes/fallback.php on line 19"

    (static::$clock = (time() - $_POST['spam_hammer']['time'])) >= $minimum_seconds;

    http://wordpress.org/plugins/spammers-suck/

  2. vbresults
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you for taking the time to report this issue; it has been fixed. To apply the fix, download the new spammers suck zip, upload the spammers-suck folder, and overwrite the old spammers suck files when prompted.

  3. cmurphy060960
    Member
    Posted 1 year ago #

    Thank you for your quick response.
    I did as instructed and spamhammer is now activated... However, when I go to SETTINGS - SPAM HAMMER 1-S, I'm getting...

    "Warning: file_get_contents(./templates/wp-admin/option-row.tpl) [function.file-get-contents]: failed to open stream: No such file or directory in /home/ch.../public_html/wp/wp-content/plugins/spammers-suck/includes/functions.php on line 449"

    line 449 as follows:

    if (!($template = file_get_contents($root . "/templates/{$name}.tpl"))) {
    			return false;

    Thanks in advance for your help.

  4. vbresults
    Member
    Plugin Author

    Posted 1 year ago #

    Sure thing.
    Fixed and released as 1.7.2.2; sorry for the trouble and thanks for reporting this one too. A lot of others will find it helpful to not run into such problems.

  5. cmurphy060960
    Member
    Posted 1 year ago #

    That did it! Thank you. Can't wait for another spammer to come along :)
    BTW, I couldn't locate v. 1.7.2.2, so I re-downloaded 1.7.2.1 and it worked. Perhaps the v. # isn't updated yet?

    Anyway, thank you for your help - great plugin! Nice to know that users won't be encumbered by spam-blocking protocols.

  6. vbresults
    Member
    Plugin Author

    Posted 1 year ago #

    Glad to hear it's all working great :)

    You are right, the version number wasn't updated; that's been fixed, thanks for noting that

    You're welcome, and thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic