WordPress.org

Ready to get started?Download WordPress

Forums

Autoptimize
[resolved] can't activate plugin (25 posts)

  1. Peter Stolwijk
    Member
    Posted 5 months ago #

    Hello people,

    i can't activate the plugin.

    I get the following message:

    'Plugin could not be activated because it triggered a fatal error'

    PHP Error Message

    Warning: include() [function.include]: Failed opening '/home/**/public_html/wp-content/plugins/autoptimize/classes/autoptimizeConfig.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/**/public_html/wp-content/plugins/autoptimize.1.7.0/autoptimize.php on line 16

    Free Web Hosting

    PHP Error Message

    Warning: include() [function.include]: Failed opening '/home/**/public_html/wp-content/plugins/autoptimize/classes/autoptimizeCache.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/**/public_html/wp-content/plugins/autoptimize.1.7.0/autoptimize.php on line 17

    Free Web Hosting

    PHP Error Message

    Fatal error: Class 'autoptimizeConfig' not found in /home/**/public_html/wp-content/plugins/autoptimize.1.7.0/autoptimize.php on line 27

    Can anyone help me?
    Thnx!

    http://wordpress.org/plugins/autoptimize/

  2. futtta
    Member
    Plugin Author

    Posted 5 months ago #

    just change "autoptimize.1.7.0" back into "autoptimize" and all should be well ;-)

  3. Peter Stolwijk
    Member
    Posted 5 months ago #

    Change where?

  4. Peter Stolwijk
    Member
    Posted 5 months ago #

    Ok i changed it. Thank you!

    But come on, this plugin breaks the whole website!
    Nothing functions when i activate this plug-in.

    What settings do i need to use for this, without my website breaks?

  5. futtta
    Member
    Plugin Author

    Posted 5 months ago #

    changing the plugins base dir. you can't, there's no setting for that.

  6. Peter Stolwijk
    Member
    Posted 5 months ago #

    Could you advise me a setting when i gave you my url's website??

  7. futtta
    Member
    Plugin Author

    Posted 5 months ago #

    sure, I can have a look :-)

  8. Peter Stolwijk
    Member
    Posted 5 months ago #

    Ok thank you!

    Url:http://goo.gl/qsgowj

  9. futtta
    Member
    Plugin Author

    Posted 5 months ago #

    I would start with "optimize HTML" and "optimize CSS", those are harmless most of the time.

    For JavaScript try with "force script in head" and see if everything still functions, if not you'll have to exclude specific scripts (jquery.js and possibly others, but that is trial and error).

    veel succes!
    frank

  10. Peter Stolwijk
    Member
    Posted 5 months ago #

    Dear Frank,

    When i optimize HTML, it doesn't break my site.
    When i optimize CSS, the font change and doesn't fit inside certain lines anymore. So i didn't enable that.
    When i enable 'force script in head' everything is fine too.

    Is it fine and effective to use your plugin, only by enable these things?
    And im also using wp supercache, is that fine too or two total different things and can work together.

    Thank you so much in advance!

  11. futtta
    Member
    Plugin Author

    Posted 5 months ago #

    Hi Peter;
    Checked your site, but I don't have the impression JS optimization is active?

    Regarding the CSS problem; there is a known issue with import-rules for external resources (i.e. the font-file from Google), hope to get that fixed for a next release (1.7.2, hopefully somewhere in December). As a temporary fix you could add that one line of CSS inline in the header.php of your theme.

    You indeed should use Autoptimize together with a "page caching plugin" such as WP Super Cache.

    hope this helps,
    frank

  12. Peter Stolwijk
    Member
    Posted 4 months ago #

    Thank you so much Frank.

    I forgot to mention that when i turn JS on, my website is not working correctly.

    It doesn't show my homepage banner and also my subpages in my menu anymore. So i couldn't turn that on. Does this mean that enabling 'force script in head' also don't have any effect because of that? Or are these things totally not connected with each other?

    Thank you in advance!

  13. futtta
    Member
    Plugin Author

    Posted 4 months ago #

    Enabling "force script in head" (possibly combined with "look only in head") could solve that problem. Alternatively you could try to identify the javascript-file(s) used for the bannering and add those to the "exclude from optimization"-field.

  14. futtta
    Member
    Plugin Author

    Posted 4 months ago #

    I've just pushed a first test-version of 1.7.2 to the plugin repository. It should fix the CSS-import problem. You can download the test-version here. Looking forward to your feedback!

  15. futtta
    Member
    Plugin Author

    Posted 4 months ago #

    I released 1.7.2 to the masses earlier today, hope it fixes the CSS import problem.

  16. Peter Stolwijk
    Member
    Posted 4 months ago #

    Thank you so much my friend!!

    I can enable css now too.

    Can i enable more now?

    Thanks in advance sir!

  17. futtta
    Member
    Plugin Author

    Posted 4 months ago #

    Well, enabling more (i.e. JS optimization) is definitively possible, but will require some configuration on your part I'm afraid (combination of "force in head", "look only in head" and possibly some exclusions).

  18. Peter Stolwijk
    Member
    Posted 4 months ago #

    Then i will leave it this way.

    You delivered me very good service sir. Thank you!

    Could you also advice me the settings for this site sir, because im also experiencing difficulty here.

    Url: http://sneap.nl/

    Thank you so much in advance again!

  19. Peter Stolwijk
    Member
    Posted 3 months ago #

    Dear Futta,

    Please can you advice me the settings for this site, because this site is very difficult for me to understand sir.

    Thank you!

  20. futtta
    Member
    Plugin Author

    Posted 3 months ago #

    Just give it a shot Peter :-)

    Optimize HTML & CSS will probably just work, after doing that I'd also activate "Optimize JS" (lots of that in there) with options "force in head" and "look only in head".

    hope this helps,
    frank

  21. Peter Stolwijk
    Member
    Posted 3 months ago #

    That's great, thank you sir!

    I did what you said, i only did not optimize JS, because the website is a few second slower when i use that.

    "force in head" and "look only in head" i did optimze.
    Can i use more now?

    Thanks,
    Peter

  22. futtta
    Member
    Plugin Author

    Posted 3 months ago #

    weird that your website would be slower when optimizing JS. if you're not optimizing JS, options such as "force in head" and "look only in head" are not important.

  23. Peter Stolwijk
    Member
    Posted 3 months ago #

    I swear the website is loading 1 second slower when i activate that Futta.
    What do you suggest now deactivate all the options under JS?

    I really hoped to hear a solution for this heavy JS on my site sir.

    Thank you,
    Peter

  24. futtta
    Member
    Plugin Author

    Posted 3 months ago #

    Well, the only reason when it would make sense for JS-aggregation to slow things down, is when there is JS on each page which changes frequently (e.g. php outputting a javascript var with a timestamp or a random value), in which case Autoptimize would have to go through the entire aggregation, minification and caching procedure for each and every request. If that is the cas, you would have to exclude those blocks of javascript that include that too variable code.

  25. Peter Stolwijk
    Member
    Posted 3 months ago #

    Oh my god, i really don't know why the javascript is even there sir.

    So also don't know what javascript can turn of.

    Yes the views are changing frequently, maybe that's the issue.

    Anyway thank you very much.

    Im afraid this is all what i can do.

    Bye

Reply

You must log in to post.

About this Plugin

About this Topic