WordPress.org

Ready to get started?Download WordPress

Forums

Amazon S3 and Cloudfront
[resolved] Cant activate: fatal error (5 posts)

  1. Mohamed.Reza
    Member
    Posted 9 months ago #

    I'm very dependent on the 'Amazon S3 and CloudFront' plugin, of which now it requires 'Amazon Web Services' plugin.

    The update 'Amazon S3 and CloudFront' went well, the installation 'Amazon Web Services' plugin was done. But when I tried to activate the 'Amazon Web Services' plugin, I got this fatal error:

    Fatal error: Cannot redeclare class Symfony\Component\ClassLoader\UniversalClassLoader in /www/ops.unartforpeace.org/html/wp-content/plugins/amazon-web-services/vendor/aws/Symfony/Component/ClassLoader/UniversalClassLoader.php on line 62

    http://wordpress.org/plugins/amazon-s3-and-cloudfront/

  2. Brad Touesnard
    Member
    Plugin Author

    Posted 9 months ago #

    The AWS PHP libraries are built on the Symphony framework. Sounds like another one of your plugins might also be using the Symphony framework. Can you try disabling all your other plugins then try enabling the Amazon Web Services plugin?

  3. Mohamed.Reza
    Member
    Posted 9 months ago #

    Thanks for the lead. It might very be a conflict with our in-house built plugin.

    If myplugin is already on, trying to load 'Amazon Web Services':
    Fatal error: Cannot redeclare class Symfony\Component\ClassLoader\UniversalClassLoader in /www/unartforpeace.org/html/wp-content/plugins/amazon-web-services/vendor/aws/Symfony/Component/ClassLoader/UniversalClassLoader.php on line 62

    If 'Amazon Web Services' is on, trying to load myplugin:
    Fatal error: Cannot redeclare class Symfony\Component\ClassLoader\UniversalClassLoader in phar:///usr/share/php/aws.phar/Symfony/Component/ClassLoader/UniversalClassLoader.php on line 62

    Feedback would be very most welcome.

    [Moderator Note: No bumping. If it's that urgent, consider hiring someone.]

  4. Brad Touesnard
    Member
    Plugin Author

    Posted 9 months ago #

    Couldn't you just disable Symfony in your in-house built plugin?

  5. Mohamed.Reza
    Member
    Posted 8 months ago #

    Solved. Seems like the UniversalClassLoader.php was declared twice. I just comment it out at one of the plugin (either my in-house plugin or your Amazon plugin), then it is good to go.

Reply

You must log in to post.

About this Plugin

About this Topic