WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't access wp-admin after changing url to the website (19 posts)

  1. Charles599
    Member
    Posted 3 years ago #

    Good morning everybody,
    This morning I've tried to change the url to my wordpress website from gregevain.com/wordpress into http://www.gregevain.com.
    I probably made a mistake by doing it directly from the settings panel in wp-admin.

    I can't access either the blog (i have still something with gregevain.com/wordpress but the css seems not to be taken into consideration anymore) or wp-admin anymore (neither with gregevain.com/wordpress/wp-admin nor with http://www.gregevain.com/wp-admin, etc).

    Could you please provide me with a solution to access wp-admin and reset the url ?

    Thank you very much.

    Regards,
    Charles

  2. vincex86
    Member
    Posted 3 years ago #

    I seem to have the same sort of problem only with fewer setbacks.

    I migrated my wordpress installation from /site/ to root. I changed my sites URL through the admin panel.

    Now the wp-admin login seems bugged. I cannot login with my credentials ( when I try to, the page reloads with no error ). Then when I reset my password, it DOES let me login with the new password. Only once.. after I logout again I have to reset the pass again to login. Very annoying..

  3. abhilol
    Member
    Posted 3 years ago #

    You are actually moving WordPress within your site and it can not be done from your admin dashboard.
    First..
    Take a complete backup of your WP folder from cPanel and download to your local computer.

    Now check this link on how to do this Moving WordPress Within Your Site .

    I will suggest you to check this post because you are unable to access your dashboard.

  4. vincex86
    Member
    Posted 3 years ago #

    I did check that link before I started moving, and did the move accordingly. I guess my post above wasn't too clear.

    Everything works fine after the move. I had to change a few urls here and there to get images working but overall the blog is running 99%. The final 1% is the admin login.

    Tried creating a second admin user but that doesn't let me login either..

  5. sales@4bco.com
    Member
    Posted 3 years ago #

    vincex86 ~ Your issue is different. It sounds as if you didn't change the path in the wp-admin for your site...

    Charles599 ~ It sounds as if you should have changed the folder your domain name links to and only that....Have http://www.gregevain.com. point to your wordpress folder & you should be good to go

  6. vincex86
    Member
    Posted 3 years ago #

    I did change the links..

  7. sales@4bco.com
    Member
    Posted 3 years ago #

    vincex86 ~ Make sure you are trying to access...

    domain.com/wp-admin

    Make sure there is no .php there. Let me know if that works

  8. vincex86
    Member
    Posted 3 years ago #

    I solved it.. in the Site Adress URL option I put http://domain.com instead of http://www.domain.com, that's why it wasn't taking my password.. thanks for the help though!

  9. Charles599
    Member
    Posted 3 years ago #

    Thank you everybody! Now it works.
    Happy to see that you have solved your problem as well vincex86!

  10. westernwoman
    Member
    Posted 3 years ago #

    Hi there,
    I seem to have done the same thing as Charles 599. I tried to change the URL in the Admin settings (but not move any files) and now I can't access wp-admin. I can see the pages in the subdirectory but no CSS is applied to them.
    Do you know how Charles fixed his to see the dashboard once again and fix the path to CSS??

    Thank you so much I am desperate!!!

  11. Charles599
    Member
    Posted 3 years ago #

    Yep I do know how i fixed this! hehe.
    You have to go in your database, with PhpMyAdmin, or whatever your hosting service provides you with. Then you have to find the good way (I cannot remember it at the moment) to access the fields (I think there are 2 or 3 of them, all in the same 'folder') which are exactly the same that the ones you have changed form the admin. Just fill them back with what was in them before you made the change.
    Don't worry it's not that complicated, find something called settings or that kind of things in your database and you should soon find out what I'm talking about!

    Good luck!

  12. sales@4bco.com
    Member
    Posted 3 years ago #

    If you domain originally worked at domainA.com and you changed the domain settings to domainB.com. Then, you can access your wp install through domainB.com/wp-admin Providing, domainB.com is set up to point to your WP folder on the server.

    If, however, your change is not intentional, the follow charles599's advise to get back in to your site.

  13. westernwoman
    Member
    Posted 3 years ago #

    Hi,
    Just wanted to say that my issue was resolved w/ the interventions of the WP Girl who discovered that somehow (in the process of trying to enter a new site name in the interface?) I had caused a bogus URL to be entered into my database. So she fixed everything! Then she gave me the most concise, excellent directions for pointing my domain to the WP installation in a sub-directory (in this case NOT MOVING WordPress but just "pointing" to it). Here are the directions - they worked flawlessly. http://askwpgirl.com/how-do-i-move-wordpress-from-a-subdirectory-to-the-root-directory/ Thank you all for the kind help!

  14. clifhirtle
    Member
    Posted 3 years ago #

    For the benefit of anyone else who stumbles on this thread by mucking up their site URLs in the Settings -> General section, you easily revert it back by accessing your MySQL database, accessing the "wp_options" table and you will see the "siteurl" row with the value of your site url listed likely right in the first row. Hit "Edit" change it back to what it should be, and you are good to go. Thanks all for a great thread!

  15. baokhangluu
    Member
    Posted 3 years ago #

    I moved my index.php to the root and kept all my other WP files in the same place. I then went to change the url in the admin page and put wordpress address and blog address to "www.mywebsite.com". All hell broke loose. My website displayed text gobbledy-gook, and I couldn't access wp-admin any.

    I went to my web host company, and we restored all the files back to when everything was still working. That didn't fix anything, so we deduce that it must be a change in the database.

    I went into myphpadmin as suggested and changed the first row to my original URL. That fixed the content problems, but now I have the text gobbledy-gook showing up at the top of my webpages, and I still can't access the wp-admin page.

    Are there more fields that need to be changed in myphpadmin?

  16. pezomatic
    Member
    Posted 2 years ago #

    Thanks clifhirtle!

  17. Samuel B
    moderator
    Posted 2 years ago #

    much simpler ways than accessing database
    http://codex.wordpress.org/Changing_The_Site_URL

  18. YoSoyAbundante
    Member
    Posted 2 years ago #

    Thanks so much Samuel B for the link...it really help me to solve this issue...and it was very simple to do...I´m very happy now :)

  19. James River Writers
    Member
    Posted 2 years ago #

    Samuel B., you are a lifesaver for posting that link! I had exactly the same problem and used FileZilla to edit the functions.php file and get my site running again.

Topic Closed

This topic has been closed to new replies.

About this Topic