WordPress.org

Ready to get started?Download WordPress

Forums

Can't access permalinks - help (13 posts)

  1. vitalichka
    Member
    Posted 4 years ago #

    Hello, trying to figure this one out.
    I wanted to change the structure of my permalinks and install 301 redirection for internal linking, when I click on permalinks inside WP, all seems to work fine except that I can't see anything, all I get is the default WP gray background, no errors, no nothing.

    I've disabled all plugins, no change.
    I've changed back to default theme, no change.

    Don't know what else to do.
    Any pointers?

    Thanks

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    - increasing the available memory?

  3. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Reset your permalink and add this code in htaccess:

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Now, check with blog posts and pages.

    Thanks,

    Shane G.

  4. robertu06
    Member
    Posted 4 years ago #

    My blog has the permalink like "p=123" When I tried to change the permalink under "Settings" >> "Permalinks", it says only "By default WordPress uses web URLs which have question marks and lots of numbers in them, however WordPress offers you the ability to create a custom URL structure for your permalinks and archives. This can improve the aesthetics, usability, and forward-compatibility of your links. A number of tags are available, and here are some examples to get you started."

    No other otpion is seen.

    What should I do?

    kindly help...

  5. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    - increasing the available memory?

  6. robertu06
    Member
    Posted 4 years ago #

    yes. I have deactivated all plugins except "Akismet" Should I deactiavte that also..?

    Still no change in the permalinks.

  7. Yes, definitely try everything that esmi suggested. What she has suggested is what we call "Troubleshooting 101". If her suggestions don't point out the cause, they'll at least eliminate the "usual suspects".

  8. robertu06
    Member
    Posted 4 years ago #

    how to "Troubleshooting 101"?

    Can you tell me in simple way...

  9. Yes, refer to esmi's original reply.

  10. vitalichka
    Member
    Posted 4 years ago #

    So I have tried everything you guys have mentioned except

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I didn't do this because I can't access permalinks to reset them as it says there, currently I am getting the
    Fatal error: Allowed memory size exhausted error.
    You can see the post here here.

    Updates aren't working and currently I cannot access the blog because I am getting the "Briefly unavailable for scheduled maintenance. Check back in a minute." error.

    I have gone back and reuploaded wp-settings.php and other files, including upgraded to WP3.0, I have had these errors since the past version of WP.

    I'll try to do this again but so far nothing people have told has helped with the Fatal error.

    Thanks for your help, if you come up with any other ideas, please let me know. BTW, it seems that when I try to do the auto update on plugins, I get the maintenance error. Before everything worked fine.

  11. vitalichka
    Member
    Posted 4 years ago #

    Okay Shane G. thanks for the help.
    I did what you said and it resolved nothing. I am where I was before.
    Anything else you think I could do?

    Thanks again everyone.

  12. I didn't do this because I can't access permalinks to reset them as it says there, currently I am getting the
    Fatal error: Allowed memory size exhausted error.

    First, try installing the Memory Bump plugin.

    If that doesn't work, here are four ways to increase PHP's memory allocation:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    
    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    
    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');
    
    4. Talk to your host.
  13. vitalichka
    Member
    Posted 4 years ago #

    Memory bump didn't help.
    Did the other three and nothing also.
    Contacted my host, waiting for response, still nothing.

    Wondering why this would still be the case on a brand new install.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags