WordPress.org

Ready to get started?Download WordPress

Forums

Can't Access After Changing Permalinks (7 posts)

  1. nscott
    Member
    Posted 9 years ago #

    I think I got a little bit too confident configuring WordPress because it's been fairly easy so far. Not anymore.

    I wanted to make my permalinks "pretty" as outlined at http://codex.wordpress.org/Using_Permalinks.

    In the WordPress admin, I updated the permalink structure to /%year%/%monthnum%/%day%/%postname%/

    However, the minute I went to view the website, I got a 500 Internal Server Error. I got the same error message trying to go back to the admin.

    I've read about .htaccess and mod-rewrite in an earlier post here today, but I was under the impression that WordPress 1.5 changes these files for you.

    Can someone explain in layman's language what to do next? I'll even go back and reset my permalink structure if I can only figure out how to go back to the admin and make the changes?

    Thanks.

  2. jennmiller
    Member
    Posted 9 years ago #

    This worked for me just a couple of days ago using 1.5. I made a blank file in Notepad and named it .htaccess with no extension or anything like that. I ftp'd it to my root and that alone fixed everything. I hope this simple solution works for you

  3. Orin
    Member
    Posted 9 years ago #

    This happened to me a little while ago when I accidentally entered an empty space in the permalink box. What I had to do was delete the .htaccess file in my blog's root folder.

    This fixed the 500 internal error, and WordPress re-created the same (correct) mod-rewrite rules the next time I saved my permalink sttings.

    As to what caused it I can't say. Be absolutely positive all characters in the box are valid.

    Hope my solution works as easily for you.

  4. nscott
    Member
    Posted 9 years ago #

    Thanks a lot. The support by fellow WordPress users is fantastic. Placing a new .htaccess file worked! I couldn't try the second option (deleting the .htaccess file already there) because there was no .htaccess file in my root folder -- is this a WordPress 1.5 thing?

    Thanks both of you for the help.

    neil

  5. moshu
    Member
    Posted 9 years ago #

    nscott

    is this a WordPress 1.5 thing?

    Nope. If one doesn't have it has to be created.

  6. jennmiller
    Member
    Posted 9 years ago #

    Well, when the directions said that 1.5 will do the work for you, I also took that to mean that I wouldn't have to do anything additional, such as create the file. It was truly a last-ditch effort to just create a file that I thought was hidden or something. I'm just really glad it worked for you!

  7. nscott
    Member
    Posted 9 years ago #

    I was pulling my hairs out about this permalink - .htaccess problem all day. One thing that was never clear to me was the step by step erasing and adding of files.

    Macmanx does a great job of explaining this in three sentences over at my hosting company, as he does here.

    http://discussion.dreamhost.com/showflat.pl?Cat=&Board=forum_troubleshooting&Number=18566&page=1&view=collapsed&sb=5&o=14&part=

    Macmanx:

    Login to your server via FTP and get to spot where you can see the .htaccess file. Then, open your browser and go to Options/Permalinks. Now, delete the .htaccess file. After that, recreate your permalink rules. A working .htaccess file should have been created in place of the old/deleted one.

    If you don't follow these directions in the exact order, you end up messing things.

    neil

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.