WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't access admin; otherwise site okay (7 posts)

  1. Rich Owings
    Member
    Posted 4 years ago #

    I've got an old site that is giving me a 404 when I try to access admin. I've looked over similar threads but haven't seen anything that looks relevant to my particular issue. All the web pages work fine.

    This is a site I created when I knew nothing and it is still on 2.2.1. I want to recover access, and then update it, preferably in that order. Any ideas?

  2. MichaelH
    Member
    Posted 4 years ago #

    Might need to get the 2.2.1 at http://wordpress.org/download/release-archive/ and upload those files to your host to be able to login.

    See Uploading WordPress to a remote host and Resetting Your Password.

    Good results reported when people at 2.2.1 upgrade to 2.3, then from 2.3 to 2.5, then 2.5 to 2.7, then 2.7 to 2.9.1.

  3. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Check with this article:

    http://codex.wordpress.org/Login_Trouble

    Thanks,

    Shane G.

  4. Rich Owings
    Member
    Posted 4 years ago #

    @Shane G - Thanks, I'll give it a try.

    @MichaelH - I'll try the less drastic approach first, but I do appreciate the upgrade path suggestions. That should be very helpful.

  5. Rich Owings
    Member
    Posted 4 years ago #

    I'm trying to work through the relevant options in http://codex.wordpress.org/Login_Trouble. I tried disabling plugins (by renaming the folder) and uploading a new wp-login.php file. That gave me a login screen, but I still get a 404 after submitting my userid/pw. I was going to try and edit the users table, but the md5 hasher isn't working for me.

    Any suggestions? Otherwise, I think I'll just try uploading 2.2.1 again as if I were updating.

  6. Rich Owings
    Member
    Posted 4 years ago #

    Here's another question. Any way to do an XML export without access to the admin panel? I'd like to have a full XML export file in case it's desirable to restore from that.

  7. Rich Owings
    Member
    Posted 4 years ago #

    Hey guys, I'm in! Re-installing 2.2.1 worked. Now I just have four more updates to do! Thanks so much for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic