WordPress.org

Ready to get started?Download WordPress

Forums

Cannot view pages (9 posts)

  1. dhkendall
    Member
    Posted 2 years ago #

    I am trying to set up a blog on http://www.nationalanthems.info/wordpress and when I create a page (you can see the links at the top, working on those as tests and once they get working I can start on the meat of the site) it comes up that the address is not on the server. I did some fiddling around with the permalinks (making the settings "custom" with http://www.nationalanthems.info/wordpress/ and adding a plugin so that the address ends in .html (helping with compatibility with the existing site), but I must have screwed something up, because the page isn't displaying.

    Please let me know where I went wrong.

  2. Harry
    Member
    Posted 2 years ago #

    Remove the plugin, and regenerate your Permalinks file (.htaccess) file and see if that fixes the problem.

    It looks as though there may be a conflict with it.

    If you can post the code from your .htaccess file that would be handy.

  3. dhkendall
    Member
    Posted 2 years ago #

    Don't know how to regenerate my permalinks file (I just created one from scratch and saved it), but the one I created looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    # END WordPress

  4. Harry
    Member
    Posted 2 years ago #

    adding a plugin so that the address ends in .html

    Did you try removing the plugin? To see if this is the problem?

    WordPress can try to create the code for the Permalinks in Settings > Permalinks? See if it matches what you have?

  5. dhkendall
    Member
    Posted 2 years ago #

    Yup, plugin has been removed. (Well, deactivated. Sasme thing?)

  6. dhkendall
    Member
    Posted 2 years ago #

    OK, it worked when I did what you requested, but when I moved the permalink structure back to plain "/" (so that I can have custom permalinks starting with the site url and ending with a filename of my choosing), I get the familiar error again. Must be something wrong with the .htaccess file I created, I'm guessing.

  7. dhkendall
    Member
    Posted 2 years ago #

    The code matches, the plugin is removed, but the problem remains, if I use any structure other than default, it gives the error of not being found.

  8. Harry
    Member
    Posted 2 years ago #

    That is normal, you're trying to point the .htaccess file away from the default wordpress install, and therefore you can't access anything (404's). This is normal. I would suggest searching for a better plugin to achieve what you're trying.

    Good luck with it.

  9. dhkendall
    Member
    Posted 2 years ago #

    I've even tried removing and reinstalling WordPress, all my plugins are removed, and it still won't let me view pages unless they are the default permalink setting. I can't even view pages if the permalink setting is "Numeric" or "Day and Name" or one of the other settings.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.