WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot View New Multi sites (7 posts)

  1. WP Sites - Brad Dalton
    Member
    Posted 1 year ago #

    Can add new site to multi site but then cannot view site.

    Could this be the sub domain setup problem?

    Do i need to do anything at the domain management level?

    Firefox can't find the server at example.domain.org.

  2. Firefox can't find the server at example.domain.org.

    Go to whatsmydns.com

    Run a scan on the subdomain.

    What comes up?

    If it's red X's you didn't set up wildcard subdomains correctly on your server.

  3. WP Sites - Brad Dalton
    Member
    Posted 1 year ago #

    The .htaccess code WordPress generates is different to what Hostgator provide:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
  4. 2tempo
    Member
    Posted 1 year ago #

    Hi,

    sounds like the same except I chose a subfolder:www.mydomain.com/IT/

    and everything shows up in main dashboard but when I click tto see the dashboard of the new site it just directs to a 404 page cant find it basically.

    I also had a an issue with the permalinks. The main site home page was there but the pages weren't being found. I realised that the permalinks had been changed by Multisite. I changed them back to default and the main site works again.

    I have sent my server (names.co.uk) an email about the .htaccess file.. still waiting for a response.

    Is it worth me trying Domain Mapping? Will this make any difference?

    Thanks for any help!

  5. Brad Dalton ... you have two WP .htaccess entries. Hostgator's is ... which one? They may not have updated for WP 3.5, so use the one WP says to use.

    2tempo, please make your own topic.

  6. WP Sites - Brad Dalton
    Member
    Posted 1 year ago #

    Looks like HG haven't updated the tutorial so i'll use the one WP generates.

  7. kooba74
    Member
    Posted 9 months ago #

    Help, I'm having a similar issue with WP Multisite subdomain install. A new site appears in network dashboard but browser can't find the new site. whatsmydns.com recognizes the new site.

    .htaccess in public_html reads:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>

    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.