WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] cannot use existing v3 forms (7 posts)

  1. pumpkineater
    Member
    Posted 9 months ago #

    Version 3.x.y.z was simple and perfect.
    Now too much bloatware in v4 ....

    Migrating from v3 to v4 and all existing forms are 'gone'...

    Reversing back to 3.1.9.2

    http://wordpress.org/plugins/si-contact-form/

  2. Don Muskopf
    Member
    Posted 9 months ago #

    I have the same problem. Existing forms are gone. Restoring settings from a back up does not work. Will revert to 3.1.9.2 for now.

    The new version looks great. Hopefully, there will be a way to restore settings so I can use it.

    Thanks.

    Don

  3. Mike Challis
    Member
    Plugin Author

    Posted 9 months ago #

    There was a mistake causing the import not to fire on upgrade, I disable the autoupdate for the new version until I fix it. I am fixing it now.
    Sorry for the inconvenience. This should only effect a few people who just updated in the last half hour only. Your forms were still saved in the 3.xx location.

    = If I upgrade from version 3.xx, will my forms and settings be lost? =
    No, it will automatic import of settings from versions 2.5.6 up to 3.xx. As long as you do not use the delete button when deactivating the plugin.
    You can and should make a backup of your forms.
    http://www.fastsecurecontactform.com/backup-restore-forms

    = What happens during upgrade from 3.xx, where are the settings stored? =

    The upgrade is run automatically only once after installing or upgrading the 4.xx version over a 3.xx versions.
    The 4.xx version uses different wp options settings than 3.xx
    The options settings are rows in the wp_options database table.

    4.xx wp_options
    fs_contact_global
    fs_contact_form1
    fs_contact_form2
    fs_contact_form3

    3.xx wp_options
    si_contact_gb
    si_contact_form
    si_contact_form2
    si_contact_form3
    si_contact_form4

    During 4.xx install, the installation looks to see if 4.xx options are not present(first time install), and if 3.xx options are present(3.xx was installed previously), if it passes both those tests, then it runs the import code in
    class-fscf-import.php

    = How do I backup or restore my forms? =

    On the Tools settings tab is a backup / restore tool.
    The backup / restore feature can be used for backups or as a site to site transfer. You can back up ALL forms and transfer ALL forms to the same or new site using the restore feature. Or you can back up individual forms and restore them to the the same or new site replacing any one form selected during the restore. Please consider that restoring one form or ALL forms makes permanent replacements to the forms already on the site you restore them to.

    Read more about backup / restore
    http://www.fastsecurecontactform.com/backup-restore-forms

  4. Andreas
    Member
    Posted 9 months ago #

    Hello,
    I have the same problem.
    I upgraded the Plugin and all the forms are gone.
    Do you know, when the bug fix is available and what I have to do?

    Regards
    Andreas

  5. michaeldayla
    Member
    Posted 9 months ago #

    The text area input field width reverted to the default on upgrade. The instructions for changing the width of the input boxes are old. How to I increase the width of all text area input fields?

  6. Mike Challis
    Member
    Plugin Author

    Posted 9 months ago #

    The first half hour of downloads yesterday had a bug that prevented the auto import from version 3.xx routine from firing. Sorry for any inconvenience.

    If that happened to you here is the help page:
    http://www.fastsecurecontactform.com/forms-did-not-import

    michaeldayla,
    You may have to reset the styles on the Styles settings tab to initialize all the current style defaults.

    If you have any more questions, please start your own post. I am marking this resolved

  7. pumpkineater
    Member
    Posted 9 months ago #

    Yeo, import/export solves problem to secure existing forms while migrating to v4.
    Only had to tweak styles again a bit...

    Fantastic work Mike !

    v4 is much better organised (inside and outside) :-)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.