WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot upload pics even though permissions are 777 (5 posts)

  1. ivobol
    Member
    Posted 6 years ago #

    Hi,

    Since I changed to WP 2.2 I cannot upload pics anymore. I have changed the file permissions to 777 for all the appropriate folders on my server. Any hints are appreciated!

    Thanks,
    Ivo

  2. microkid
    Member
    Posted 6 years ago #

    What kind of errors are you seeing? Did you chmod the month directories as well? 09, 10, etc.

  3. cjraven
    Member
    Posted 6 years ago #

    As the previous poster pointed out, the chmod needs to be recursive - thus

    #chmod 777

    wp-content/uploads won't do it. Instead, you need to do:

    #chmod -R wp-content/uploads

    If you're still jammed, then I would suggest checking the "owner" and "group" of the upload directory. If you have access to a shell, that is. If not, then contact your hosting provider and ask them to adjust ownership. The web server needs to be able to write to wp-content/uploads/ and all subdirectories beneath (2007/10 2007/09 etc etc)

    HTH
    /me

  4. ivobol
    Member
    Posted 6 years ago #

    Thanks for the input.

    The error I get is:

    "Unable to create directory /var/www/vhosts/ivobol.nl/httpdocs/blog/wp-content/uploads/2007/10. Is its parent directory writable by the server?
    Back to Image Uploading"

    All the subdirectories are chmod 777, and I can upload picture with FTP and adjust the code (so I guess the Owner and group permissions are ok) but I cannot use the WordPress editor. I can just carry on wth my Blog using ftp, but it is still a mystery...

  5. ivobol
    Member
    Posted 6 years ago #

    WP 2.2 created a yearly based structure for storing uploads. When I changed this back thru Options | Miscellaneous / Organize my uploads into month- and year-based folders OFF I had no more problems with uploading.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.