WordPress.org

Ready to get started?Download WordPress

Forums

Cannot upload images ---- please help (9 posts)

  1. Marbles471
    Member
    Posted 2 years ago #

    Hi. I am very new to all this and am not very knowledgable about computers.
    I am trying to start a webcomic here and am unable to upload any images at all. I have installed the ComicPress plugin and everything, and have been trying to upload images from my hard drive. Whenever I try, I get the same message:

    The following files were not uploaded, or the permissions on the uploaded file do not allow reading the file. Check the permissions of both the target directory and the upload directory and try again:

    I've been trying without success to google my way through this problem, but all the forums on the subject I've been able to find are way over my head. I understand that there are settings I have to manually change, but I don't understand how they work, what I'm changing them to, or even where to find them.

    If anybody can take the time to help me with this issue, I'd be very grateful. Thanks.

  2. jnhghy
    Member
    Posted 2 years ago #

    Hi,
    The best thing to do is to contact your hosting provider, it seems there are some issues with the permissions on the uploading folder and they are the ones how have access to these settings and other image/upload related settings. e-mail them and they will help you with this.

  3. Marbles471
    Member
    Posted 2 years ago #

    Uh oh. I don't like where this is going.
    My host is GoDaddy, and when I called them, they were unfamiliar with the problem and said that it was an issue on WordPress's end.

  4. jnhghy
    Member
    Posted 2 years ago #

    Well the thing is that there is no wordpress end :)),
    now to get back to the issue ... you have an error message that says:

    The following files were not uploaded, or the permissions on the uploaded file do not allow reading the file. Check the permissions of both the target directory and the upload directory and try again

    -from this error message I understand that there are some permission issues. This means that the folder that the program is using has a different owner/permission then the standard for the program to use. Permissions are set up by super-users on the server that holds your site.
    Now it will be very unprofessional for a hosting company to say that they are unfamiliar with directory rights ...
    You might want to get some extra info from them about the permission rights on your directories on their server.
    I know I don't sound very pleasant in this reply and i'm sorry for this.
    Check the codex info about file permission also it will give you some pointers about this.
    Hope you can solve this...
    Regards

  5. Frumph
    Member
    Posted 2 years ago #

    Do you have /comics /comics-rss /comics-archive /comics-mini directories created in your root installation of WordPress .. to set their permissions you FTP in and right click each one and set them to 777 with Godaddy.

    Either way, I do not recommend using ComicPress with Godaddy. Use Comic Easel w/ the Easel theme instead.

    http://wordpress.org/extend/plugins/comic-easel/

    http://wordpress.org/extend/themes/easel

    http://comiceasel.com/

    The Comic Easel plugin doesn't require any specific permissions to be set to work, like ComicPress does.

    I also am the developer of both ComicPress and Comic Easel. I'm steering everyone away from ComicPress to use Comic Easel, a much better product for doing webcomics with.

  6. Marbles471
    Member
    Posted 2 years ago #

    Wow. Frumph, it sounds like you're EXACTLY the person I need to be talking to.

    Disregarding the second thing you said for one moment---
    As I said in the first post, unfortunately I'm very new to this stuff and don't know a lot of the basic things many others take for granted. So forgive me if I'm asking questions that amount to "What color is the sky?"

    I can't find the directories you name---comics, comics archive, comics rss or comics mini anywhere in the GoDaddy FTP. I know where they're mentioned on WordPress itself, in the "ComicPress Manager," but I can't find them in GoDaddy. I've looked everywhere, including the "comicpress" and "comicpress manager" folders under wp-content. However, my ignorance is showing when I say I don't know what the "root installation" of WordPress is. If you mean something along the lines of what I think you might mean, I did not download WordPress myself---my GoDaddy purchase was the kind of setup where they install it for you. If that makes a difference in terms of what you were saying, let me know.

    Regarding the other thing----possibly using Comic Easel instead. Well, THERE's a curveball. Can you explain to a dummy how he would go about doing that if he chose that path? I went to the links you provided, and I have a feeling that with MY kind of luck (and inexperience), I wouldn't know what I'm doing in trying to download it and apply it to WordPress.

    Thanks for your time----I really, really appreciate it, because this has been incredibly frustrating. It's hard when you don't know what you're doing, and you've spend weeks trying to find someone who can help.

  7. Frumph
    Member
    Posted 2 years ago #

    Plugins -> add new search for "ComicPress Manager" install and activate it. Then there will be a comicpress section of your wp-admin. Click on the comicpress options and it will ask you to create the directories you need, click yes.

    If it doesn't show that, at the bottom of comicpress -> options is the option to create those directories.

    (not the appearance -> comicpress options, but the wp-admin -> comicpress -> options)

    BUT I DIGRESS, you HAVE the comicpress manager plugin installed if you got the error message you said you did above. The problem is the directories were not created OR if they were you need to set the permissions on them.

    You can check what plugins you have installed by going to the plugins section of your wp-admin.

    Also, just to make this note. ComicPress is a theme, check your appearance -> themes you will note the comicpress theme is installed - I hope.

    Check the comicpress section where you clicked upload, there's an options section of that, at the bottom is create directories, click that if you can then get back with me.

    If it still doesn't work, then we need to teach you how to FTP in and set those directories permissions.

  8. Marbles471
    Member
    Posted 2 years ago #

    I went into Plugins (I'm assuming you mean the one under wp-content, right?), but I don't understand what you mean by "add new search for ComicPress Manager." I don't see any options to search for anything.

    Also, no ComicPress folder exists inside of wp-admin at all, so neither does the Options folder you pointed me towards.

    ComicPress Manager does already exist under Plugins, though.
    And Options does appear under Themes->ComicPress. But I don't see that there's any way to "create" anything in there. What am I supposed to be seeing?

    This is all very confusing...

  9. Frumph
    Member
    Posted 2 years ago #

    If comicpress manager is activated then you should see the comicpress section of the dashboard

Topic Closed

This topic has been closed to new replies.

About this Topic