WordPress.org

Ready to get started?Download WordPress

Forums

Cannot upload images anymore??? (7 posts)

  1. faithmama
    Member
    Posted 4 years ago #

    I have four blogs and I am getting error messages on all four when trying to upload images. It has all of a sudden happened - it was working fine up until now. I use Dreamhost and they said all is fine on their end.

    When I try to upload using the browser method, I get the following message:
    "Error trying to upload media"

    When I try using the flash browser, I get the following message:
    "Unable to create directory... Is its parent directory writable by the server?"

    HELP PLEASE!!!

  2. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Assign 755 recursive permissions to wp-content directory which will resolve the problem. You can assign recursive permissions with the help of your web hosting service provider.

    Thanks,

    Shane G.

  3. faithmama
    Member
    Posted 4 years ago #

    Thanks, Shane... but they already are all assigned 755.

  4. Inspired2Write
    Member
    Posted 4 years ago #

    faithmama,
    Did you add some sort of an image plugin to your 4 blogs, that may be creating the challenge? Did you make a change to your web browser settings like for java script?

  5. WPpremium
    Member
    Posted 4 years ago #

    Assign 777 permissions to your upload directory and then try to upload media. If it works, revert the permissions to 755 and then try again to upload media.

  6. faithmama
    Member
    Posted 4 years ago #

    Inspired2Write - I have added nothing new to any of the blogs. I only have a couple plug-ins on each one, but they have been there since inception of the blogs.

    WPpremium - I tried assigning to 777 and it didn't work.

    This is really frustrating. Wish there was someone to call and to have fix this.

  7. WPpremium
    Member
    Posted 4 years ago #

    You may need to assign 777 permissions recursively to your upload folder (chmod -R upload on Linux). If you do not have SSH access, you can contact your host to set the permissions for you.

Topic Closed

This topic has been closed to new replies.

About this Topic