WordPress.org

Ready to get started?Download WordPress

Forums

Cannot upload image (6 posts)

  1. smagnu_dk
    Member
    Posted 1 year ago #

    When i want to upload an image it says: Unable to create directory wp-content/uploads/2013/01

    I use xampp - localhost.
    I use mac.

    I have not uploaded the wordpress database because i already have a website. I would like to keep this website until the wordpress is made.

    I cannot use the filezilla then to change the file permissions on my wp-content.
    How can i change the permissions to 755?

    Please, help me!

  2. Phil
    Member
    Posted 1 year ago #

    You can change permissions using filezilla (right click on Uploads folder) or through your hosting control panel 'File Manager'.

    You will only need to change the permissions of the Uploads folder - NOT the whole wp-content.

    Make sure when you change it on 'Uploads', that you select 'recursively' option which will also change permissions of every folder inside the uploads folder as well. WordPress will be able to then access the folder and create new folders inside, eg, 2013/02, 2013/03 etc...

    Hope this helps.

  3. smagnu_dk
    Member
    Posted 1 year ago #

    thank you for you help, but i cannot see the upload folder. and where is the recursively option?

  4. Phil
    Member
    Posted 1 year ago #

    Uploads folder is in wp-content folder - same as your themes and plugins folder.

    In Filezilla, you click on it once to highlight it, then you right-click on the same Uploads folder, you need to choose 'File Attributes' or 'File Permissions' (depending which screen you're viewing). You can then change permissions to 755, 777 etc.

    There will be a checkbox for recursive option.

  5. smagnu_dk
    Member
    Posted 1 year ago #

    No there is no uploads folder in the wp-content folder.

    I cannot use the filezilla to change the permissions because i have already a website set to the domain, and i want to keep that until the wordpress is ready to be uploaded.

    what to do then?

  6. purplewelshy
    Member
    Posted 1 year ago #

    Go to settings - media
    You have to specify the location of the uploads directory there
    create the apropriate directory if needed i.e. wp-uploads

Topic Closed

This topic has been closed to new replies.

About this Topic