WordPress.org

Ready to get started?Download WordPress

Forums

cannot upload files from admin (19 posts)

  1. ThomasCarreno
    Member
    Posted 9 years ago #

    get the following error and i set permissions on my image directory to 777

    double checked the path too..

    It doesn't look like you can use the file upload feature at this time because the directory you have specified (/opt2/home3/bestonlinetrades/public_html/wp-content/images ) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos.

    ????

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    This error usually happen when WP and you are looking at different folders.

    Try making a different folder and chmoding that one.

  3. ThomasCarreno
    Member
    Posted 9 years ago #

    ok thanks fixed it..

    all i did was add an extra backslash / after the word images in the admin setup section (options/miscellaneous)

  4. paulbriandeberry
    Member
    Posted 9 years ago #

    i'm still a little cunfused on how to fix this

  5. He changed
    /opt2/home3/bestonlinetrades/public_html/wp-content/images
    to
    /opt2/home3/bestonlinetrades/public_html/wp-content/images/ (notice the new trailing slash).

  6. paulbriandeberry
    Member
    Posted 9 years ago #

    thanks it didn't work for me...

  7. Did you set the permissions for the image directory to 777?

  8. nanuf
    Member
    Posted 9 years ago #

    Hello,

    I'm new with WordPress and I have the same problem as the one above. I'm setting the Destination Directory:
    /var/www/html/wp-images/wp-southbites/
    and the URL:
    http://www.southbites.com/wp-images/wp-southbites/
    getting the following error message:
    ---
    It doesn't look like you can use the file upload feature at this time because the directory you have specified (/var/www/html/wp-images/wp-southbites/) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos.
    ---

    You mention something about changing the permissions for the image directory to 777. What do you mean and where/how can I change it?

    Thanks a lot for your help. It's very much appreciated

  9. Rundy
    Member
    Posted 9 years ago #

    In regards to changing the permissions . . . the most common way this is done is with your ftp program.

    See:

    http://codex.wordpress.org/Changing_File_Permissions

    Hope that helps

  10. Lori
    Member
    Posted 9 years ago #

    Nanuf do you have a control panel with your webhost? If you go into your file manager in your control panel there will be a link called "CHMOD" that will allow you to change each file's/directory's permissions. Just click on your "wp-southbites" and your "wp-images" directorys and it should have the option to CHMOD those directories.

    When the upload feature in your blog doesn't allow you to upload it is because those directories are not allowing wordpress to upload files to them. You have to give wordpress permission by changing the permissions to a higher number such as 777.

    If your control panel does not have a way for you to CHMOD or change permissions then ftp clients will. I use cpanel and they do allow you CHMOD. If you rather use ftp, then all you have to do is right click on the directory and go down to "CHMOD" and change the permissions there.

  11. alfh
    Member
    Posted 9 years ago #

    I have a similar problem. After I did CHMOD 777 on the wp-content directory I can upload files OK with WP.

    But if I try with Photopress I get the "it doesn't look like"- error message, regardless of CHMOD setting on the photos folder, and whether or not I use a trailing slash in wp-admin/options-general.php?page=photopress.php (photos, photos/)

    Any ideas? Thankful for all help.

  12. alfh
    Member
    Posted 9 years ago #

    I actually figured out what went wrong:

    WordPress was in the directory:
    httpdocs/wordpress/ so I created
    httpdocs/wordpress/wp-content/photos/

    but Photopress was looking for
    httpdocs/wp-content/photos/

    I'd consider this a bug, as there is no way you can change settings in the admin panel to make it look elsewhere - you have to start messing with code...

    Easily solved though, when I install wordpress directly under httpdocs. Hope this might be helpful to someone.

    Alf

  13. kepa
    Member
    Posted 8 years ago #

    Daer WP friends

    I wish to ask for your help. Just installed WP 2.0 and when I try to upload an image it says:

    "Unable to create directory /home3/www/interlabs/blog/wp-content/uploads/2006. Is /home3/www/interlabs/blog/wp-content/uploads writable?
    Back to Image Uploading"

    I hage created this diretory "blog/wp-content/uploads/2006" in all of the prmissions to write are open.
    but
    "/home3/www/interlabs/" has been genarated by WP 2.0 , I dont know why. "interlabs" is part of the url.

    Do you know why I cant upload files ? How can I solve it?

  14. moshu
    Member
    Posted 8 years ago #

    1. You don't really have to create those folders - just make wp-content writable and WP will create the directories.

    2. /home3/www/interlabs/blog/wp-content/uploads is NOT an URL, is the internal server path to your folder.

  15. kepa
    Member
    Posted 8 years ago #

    Thanks Moshu,
    I didn't try to create directories but WP does not create them neither. I dont know why.
    In fact the ftp directory is:
    interlabs.tv/home/interlabs/www/blog/wp-content/uploads/

    Quite simmilar to the WP is looking for or trying to generate
    /home3/www/interlabs/blog/wp-content/uploads
    But it does not
    I know that this directories a writeble
    www/blog/wp-content/uploads/

    But there is no /home3/

    Could change something in the code to make WP upload in certain directory? My be in a particular option or the inline-upoading.php?

    Thanks

  16. moshu
    Member
    Posted 8 years ago #

    1. Don't bother about URI and paths (better to say: google and learn about the differences!)
    2. wp-content has to be writable for WP to be able to create directories under it.

  17. boneless
    Member
    Posted 8 years ago #

    in wordpress 1.5 in the admin panel i could choose my own path for upload. in 2.0 it can't, why not? i don't want to upload files in the wp-content folder, i want them to go with the other uploaded files in the boneless.nl/files folder. Is there anyway to do this?

  18. hristov
    Member
    Posted 8 years ago #

    i've got wp sat in a 'wordpress' directory rather than at the root (for tidiness' sake).

    i want to upload through the interface but i don't want to upload to blah.com/wordpress/wp-content/files because this url will be visible to visitors. instead i want to use blah.com/files for uploads.

    how can i do this? i've tried a direct path and also ./ etc with no luck.

  19. Sproke
    Member
    Posted 7 years ago #

    I'm having a problem with photopress (2.02 & 2.05 - two different sites) not uploading to the directory created, even though all the settings are right, CHMODS and pathnames. I have no idea why it is happening. I've uninstalling and installing again, clearing the cache each time, but I just can't fix it.
    PLEASE HELP! am a little desperate, as want it to be easy enough for my Mum to do by herself!!
    Thanks in advance!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.