WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot Unset String Offsets on brand-new installation (5 posts)

  1. felixlockhart
    Member
    Posted 6 years ago #

    Greetings! I'm in the process of installing WordPress for one of my hostees (we're small, free hosting provider), and I'm having a problem that, according to what I found in my searches here, shouldn't be a problem anymore.

    The initial installation process went smoothly, but when I tried to login, I received a PHP error: "Fatal error: Cannot unset string offsets in C:\Inetpub\websites\howlingotter\houseblog\wp-includes\widgets.php on line 315"

    Now, I did some searching before posting this, and the only relevant information I could find was over half a year out of date, which would indicate that this has long since been fixed. I tried a few of the suggested solutions anyway, but with no luck, and I was reluctant to try some of the patches/code modifications on a newer version where the problem may not have the same cause.

    So, does anyone have any suggestions? The server hasn't been up very long, maybe a few weeks, but I've installed multiple other PHP and ASP applications without any trouble, so I think we can rule out a server-wide PHP problem.

    Here are the system specs, I appreciate any help y'all can give:

    OS: Windows 2003
    Web Server: IIS 6.0 w/ ISAPI_Rewrite (no rewrite rules applied to this directory)
    MySQL Version: 5.0.45
    PHP Version: 5.2.5
    WP Version: 2.3.3 (just downloaded it tonight)
    Location of blog installation: http://house.howlingotter.com/

  2. felixlockhart
    Member
    Posted 6 years ago #

    Forgot to mention, after the failed attempt to login, I was able to view the front page once. I clicked the login link from there, and I now receive this error on every page, including the installation pages.

    Also, here's a PHPInfo link, all settings are server-wide since it's IIS: http://admin.lupinia.net/phpinfo.php

  3. felixlockhart
    Member
    Posted 6 years ago #

    Not that anyone is reading this topic, but it's fixed now. Apparently, the need to have magic quotes turned off is more severe than I realized. Unfortunately, since it's an IIS server, all setting changes are global, and some of my other applications need magic quotes to be turned on.

    Fortunately, adding ini_set() commands to the wp-config.php file solved the problem. Since this appears to come up from time to time, you guys really should add this instead of relying on the user to already have their PHP installation configured to your liking. Failing that, there should be very clear information in the installation documentation about this, because it's not uncommon to have magic_quotes_runtime and/or magic_quotes_gpc turned on.

    If anyone reading this at a later date needs to know how to do this, I suggest this article in the PHP documentation: http://us.php.net/manual/en/function.ini-set.php

  4. soylent
    Member
    Posted 5 years ago #

    I am reading this topic and you just saved me a lot of work! Thanks!

  5. NateEquity
    Member
    Posted 5 years ago #

    Thanks, saved me as well, just had to set magic_quotes_gpc and magic_quotes_runtime both to '0' in the config file and it all worked again.

Topic Closed

This topic has been closed to new replies.

About this Topic