WordPress.org

Ready to get started?Download WordPress

Forums

Cannot stop metadata (author, date etc) showing up on posts (7 posts)

  1. hannahstrange
    Member
    Posted 1 year ago #

    Hello,

    I am using the Oxygen theme and I cannot stop the meta data (I believe it is the meta data - author, date etc?) showing up on posts. I am trying to set up a magazine not a blog so I don't want the poster showing on the site. I have tried everything I can think of, I've changed CSS code according to the instructions given by WordPress and other users, and I'm using a layout where it says that all of this is set to hidden, but nothing is stopping it showing up. Please help as this very simple detail (you couldn't just provide an option, Oxygen makers?) is taking up all of my working time at present, and quite frankly I'm thinking I might have to leave WordPress entirely...

    Thanks!

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Without a link to your site, no way for anyone to offer much help or look at what is going on with the CSS code. Generally, you can hide that using just CSS.

  3. hannahstrange
    Member
    Posted 1 year ago #

    Sorry I should have included that. It's thisweekshealth.com. You can see that underneath the post, such as on the front page, it says posted by me on Nov 14th. This is not a blog that we are creating but a magazine, of which I am editor, so these articles will need individual bylines if they have anything at all (in many cases we won't want anything to show).

    I have tried to hide it using CSS and have followed all of the CSS instructions to do so, but nothing is working. Either I'm doing something really wrong or Oxygen perhaps has an override (I did see something about integrated metadata on posts in the theme description).

    Any thoughts much appreciated!

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I don't know what you tried, but this should do it -- add this to your custom CSS or child theme CSS file:

    .byline, .home.singular .byline {
       display: none;
    }

    Make sure that you are NOT making changes in any theme files -- or they will be lost when the theme is updated.

  5. tutiP
    Member
    Posted 1 year ago #

    Hi hannahstrange and WPyogi,

    I am trying to do exactly what you, hannahstrange, described. I put

    .byline, .home.singular .byline {
    display: none;
    }

    in my child theme, but nothing worked. Did it worked on your site?

    The site that I am trying to do that on is - http://www.eventsinbulgaria.com

    I would be very happy if someone already did that and shares his/her experience.

    Thanks!

  6. hannahstrange
    Member
    Posted 1 year ago #

    Thanks WPyogi, that worked! I appreciate your help. Yes tutiP, I had success, I posted this in the custom css box in the theme settings section, just on its own, and that sorted everything out.

  7. tutiP
    Member
    Posted 1 year ago #

    Hi, hannahstrange, thanks very much for sharing! I read your post and I tried again, this time it worked! :)
    WPyogi thank you too!

Topic Closed

This topic has been closed to new replies.

About this Topic