WordPress.org

Ready to get started?Download WordPress

Forums

WPArtists
[resolved] Cannot save Artist / Label / Music (5 posts)

  1. Denis Ciumbargi
    Member
    Posted 1 year ago #

    This one came on auto-save

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'wpa_artist_save_meta' not found or invalid function name in /.../html/wp-includes/plugin.php on line 406

    Another error on publish, had to refresh, took me to a blank add new.

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'wpa_artist_save_meta' not found or invalid function name in /home/content/35/8355835/html/wp-includes/plugin.php on line 406

    Warning: Cannot modify header information - headers already sent by (output started at /.../html/wp-includes/plugin.php:406) in /.../wp-includes/pluggable.php on line 876

    Artist added if you check under artists menu.

    This also breaks all other regular post / pages to be saved! BROKEN!

    And still want to sell premium, come on...

    http://wordpress.org/extend/plugins/wp-artists-lite

  2. b4ucode
    Member
    Plugin Author

    Posted 1 year ago #

    I'm sorry sir, but this is my first time adding a plugin to the WordPress directory. I didn't receive the error prior to uploading. The plugin has been fixed, I am just trying to get my head wrapped around how to properly use the plugin directory here.

  3. Denis Ciumbargi
    Member
    Posted 1 year ago #

    @b4ucode - Working around it is good, i am happy to see an answer and the will to work

    I will wait for the update.

    Thank you and in order to help you develop a good plugin i will report here other errors if any.

    And, no worries, it will be ok if you work on it! :)

  4. b4ucode
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks. I tried to make an update but am not sure WordPress has updated everyone on the new release. You can download version 0.0.2

  5. Denis Ciumbargi
    Member
    Posted 1 year ago #

    I have updated and it seems to work fine.

    I lost the function to associate the artist with an existing user from my list of users which i really liked.

    Was that what was causing the error reported earlier? Hope not, because i was happy to be able to associate the artist with an user.

    Thank you for fixing this!

    Some advice: Add a change log here on WordPress repository when you do an update so people know what is fixed so they can report other errors that an update might cause, that will help you also more.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags