WordPress.org

Ready to get started?Download WordPress

Forums

Cannot review page as I edit - oops page not available (13 posts)

  1. djm129129
    Member
    Posted 4 years ago #

    I am creating my first wordpress blog. Upon editing my post, I can view it. Building my 'about me' page does not allow me to view. I keep getting the oops page not found error. When I arrive through the search engine, I can see that the 'about me' page has been linked, but when I click on the link, again I get the error.
    Consider this a grade 1 question. I have just started working with web pages and having difficulty understanding ftp in this case.
    Thanks.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Site url?

  3. djm129129
    Member
    Posted 4 years ago #

    http://www.housegenereators.org

    Do I have to manually build my directory for each wordpress page I design? I thought that was what wordpress did. How do I go about setting this directory?
    Thanks.

  4. Scoe
    Member
    Posted 4 years ago #

    I cant get onto that link at all...

    and no you dont need too, the PHP code sorts it all out for you

  5. djm129129
    Member
    Posted 4 years ago #

    My apologies...

    I just noticed typo:

    http://www.housegenerators.org

    thanks for your help!

  6. Scoe
    Member
    Posted 4 years ago #

    hmmm, well I can see the website now.

    Im not too sure what the problem is with the about me link, however I would delete the page and re-make it.

    Check that your permalinks are set up correctly too
    also check the link that the page is giving, go edit > then its near the top, check that its the same as the link on the wesbite. (it should be, but doesnt hurt to check)

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    hmm...I'm trying to figure out what you are doing.....

    Are you building your 'about me' page through wordpress? Why do you need ftp?

    Are you building the page on your own and trying to ftp it?

  8. djm129129
    Member
    Posted 4 years ago #

    yes, Im building everything in wordpress. I was told by some support forum its an ftp issue, of which I dont understand. That said, I began my first post, viewed it without problems, began building my about me page, and it simply will not allow me to view/preview it. The link is definitely there, but the page does not come up. Id just like to know why I cant see it and what I can do about it.
    To be honest, Im not sure how the permalinks work, but Im sure its set properly.

    Thanks for trying to find a solution to this!

  9. djm129129
    Member
    Posted 4 years ago #

    Ok, I just attempted to delete my about me page and this is the error I have:

    500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.

    Have I potentially missed a very basic step in setting up this site??

  10. Scoe
    Member
    Posted 4 years ago #

    do you have access to your database?... if yes... check that there is a about me post in the wp_posts table.

    If its not in there then your db connection has gone wrong somewhere.

    Otherwise, I have no idea what has gone wrong :S

    =]

  11. esmi
    Forum Moderator
    Posted 4 years ago #

    Where did you install WordPress on your site/domain and what site url did you enter on Admin/General/Settings?

    Reset your custom permalinks to the default setting, for a start, then try reading:
    http://codex.wordpress.org/Using_Permalinks
    before setting a custom permalink structure back up again. %postname% is not a good permalink structure to use.

  12. djm129129
    Member
    Posted 4 years ago #

    Thanks again guys.

    As it stands, Ive removed the about me page and started again. Now I can view/preview it and have published the page. I had to remove the custom permalink back to default.

    Ive read through your link on permalinks, but I am still unclear as to the best option.
    As well, I am trying to upload a file through my ftp. I have placed the file, but everyone talks about ensuring its in the public html. I dont have that directory. All I have listed is wordpress files.
    I know this is painful for most of you. Im new to this game, but working hard.

  13. Nile Flores
    Member
    Posted 4 years ago #

    You might want to ask if your host will allow you to use the pretty permalinks or even have access to .htaccess

    There may be an issue where you need to update your .htaccess to allow you to use the /postname%/ for your permalinks.

    If you have not updated your .htaccess file...which sometimes your WordPress admin panel might give you an output of this when you select how you want your links to display in Settings>Permalink (at the bottom of the page after you submit your preferences.)

    If copying and putting a .htaccess file up does not work, I would ask your host if they allow it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.