WordPress.org

Ready to get started?Download WordPress

Forums

Cannot resolved WSoD with custom Twenty Eleven theme (3 posts)

  1. geekasms
    Member
    Posted 1 year ago #

    Okay, I've been searching the forums, online, everywhere, and while I think I'm close, I can not figure out where my problem is. The site was working a month ago, and then it was suddenly broke, and I can't figure it out, except I'm fairly certain its the coding within header.php which looks like this

    <?php
    /**
     * The Header for our theme.
     *
     * Displays all of the <head> section and everything up till <div id="main">
     *
     * @package WordPress
     * @subpackage Twenty_Eleven
     * @since Twenty Eleven 1.0
     */
    ?><!DOCTYPE html>
    <!--[if IE 6]>
    <html id="ie6" <?php language_attributes(); ?>>
    <![endif]-->
    <!--[if IE 7]>
    <html id="ie7" <?php language_attributes(); ?>>
    <![endif]-->
    <!--[if IE 8]>
    <html id="ie8" <?php language_attributes(); ?>>
    <![endif]-->
    <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
    <html <?php language_attributes(); ?>>
    <!--<![endif]-->
    <head>
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    <meta name="viewport" content="width=device-width" />
    <title>
    				<div class="skip-link"><a class="assistive-text" href="#content" title="<?php esc_attr_e( 'Skip to primary content', 'twentyeleven' ); ?>"><?php _e( 'Skip to primary content', 'twentyeleven' ); ?></a></div>
    				<div class="skip-link"><a class="assistive-text" href="#secondary" title="<?php esc_attr_e( 'Skip to secondary content', 'twentyeleven' ); ?>"><?php _e( 'Skip to secondary content', 'twentyeleven' ); ?></a></div>
    
    				<?php wp_nav_menu( array( 'theme_location' => 'primary' ) ); ?>
    			</nav>-->
                <!-- #access -->
    	</header><!-- #branding -->
    
    	<div id="main">
    
          <!---->

    And for anyone wanting to look, the site in question is
    Any help, ideas, anything would be extremely appreciated because right now, I'm stuck.

  2. alchymyth
    Forum Moderator
    Posted 1 year ago #

    that is some seriously broken header.php

    - try to upload a copy from a fresh download of the Twenty Eleven theme from http://wordpress.org/extend/themes/twentyeleven

  3. geekasms
    Member
    Posted 1 year ago #

    Oh I know! I've been trying to diagnose a previously made theme for someone else, because the company refuses to support the broken theme. I've gotten most of it squared away, but can't figure out what they were doing in some of the coding or with the top menu. I load a fresh copy of header and the menu is a mess.
    I can't determine what these idiots did, and of course they want to keep their theme.

Topic Closed

This topic has been closed to new replies.

About this Topic