WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot remove/update theme or plugin (even after deleting from server) (5 posts)

  1. pkipper
    Member
    Posted 7 years ago #

    Hi all, I am having this strange problem, that I am unable to remove or update any themes or plugins.

    Say I have this theme called Theme1, and I deleted the entire folder of Theme1 from wp-content/themes, but Theme1 still shows up under WP's Presentation/Themes tab, and the theme still works if I choose it.

    Same thing goes with Plugins. After deleting a plugin from server, it still remains and working in WP. If I copy a new plugin to wp-content/plugins, it does not show up in WP's Plugins tab.

    I have tried to rename the whole folder (eg. from wp-content to something else), and it still does not help, and everything still remains.

    I upgraded to WP 2.2 from WP 2.1, but it seems upgrading does not do as well, and it still says WP 2.1.

    What is happening??? This is driving me nuts.

  2. whooami
    Member
    Posted 7 years ago #

    if you are seeing items in the theme presentation area that you think you deleted -- then you didn't delete them.

    Additionally, if you are still seeing 2.1 as your version number in the admin area, then you didnt follow the upgrade instructions, which state:

    Delete ...

    Upload ...

    The wordpress version is stored in file. If the version number doesn't change you didnt delete and then upload that new file.

    I would hazard a guess that you have a WWW directory when you ftp in, and that you have been tinkering with that directory, and not the directory you need to be tinkering with.

    WWW is a symlink, it should be left alone for purposes of what you are doing.

  3. pkipper
    Member
    Posted 7 years ago #

    Thank you for the reply.

    I find this really weird because this problem never happened before and this is the first time. I have not changed my .htaccess or database or my WP at all but just right now it seems everything is fixed, regardless if I update anything or remove anything. Posting and managing posts still work fine though.

    You are right, I do have a WWW directory. What do you suggest I should do right now? I thought I did delete WP 2.1 completely but now I am just really confused.

  4. pkipper
    Member
    Posted 7 years ago #

    Hello. Can someone enlighten me on this? Thank you all.

  5. pkipper
    Member
    Posted 7 years ago #

    Hi all, suddenly, my site is back to normal now. I am not sure why, or what happened, but everything is OK now.

    Strange, perhaps it was something with the server configuration or Apache.

    Thank you all still. Gotta love WP.

Topic Closed

This topic has been closed to new replies.

About this Topic