WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cannot remove from sidebar else breaks (10 posts)

  1. Saurus
    Member
    Posted 5 years ago #

    Okay - it's my turn to ask for assistance:(

    I have been screwing around for the better part of an hour trying to remove the following dead link from my sidebar. Every time I do - it breaks the blog - pushing the content under the footer.

    I have checked for open divs and find nothing. I've removed the previous and following links without a problem, and replaced them one at a time with no problem. But remove the one link and it breaks.

    I don't have that much hair left to spare and I want this link gone. If one of the older hands around here can see any reason WHY this damned thing will not let itself be deletec ... I'd love to hear it!

    <center>
    <link rel="stylesheet" href="http://victorycaucus.com/windowfiles/dhtmlwindow.css" type="text/css" /> <script type="text/javascript" src="http://victorycaucus.com/windowfiles/dhtmlwindow.js"> </script> <a href="#" class="textlink" onClick="googlewin=dhtmlwindow.open('googlebox', 'iframe', 'http://66.114.231.46/petition/petition.show?ppid=VIZWVTRHBEVAHCXJRNFYMCOCIONTGAKG', 'Stand By The Mission', 'width=750px,height=630px,resize=1,scrolling=1,center=1', 'recal'); return false"> <img src="http://victorycaucus.com/petitionad.jpg" style="border-style: none" alt="Sign the Stand By The Mission Petition!"></a>
    <center />

    My Blog
    (The applicable link is in the "Important Links" div, under the blogroll. "Victory caucus" is the one.

  2. iridiax
    Member
    Posted 5 years ago #

    To narrow down which tag in the above code is causing it, try removing one tag pair (from open to close) at a time, working from the inside out. Once you know which tag it is, look for an error with that same tag elsewhere on the page that may have been masked by the presence of this code.

  3. Saurus
    Member
    Posted 5 years ago #

    I'm not following that. "1 tag pair at a time"? I already removed every other div on the sidebar without a problem and then replaced them. Only this one breaks the page. Frustrating as all hell. It doesn't even leave the page when clicked - it draws right over the open page. Hovering over the code yields - instead of the url to the form - the blogs own url following by a pound sign. Never did when the links original url was active.

  4. Saurus
    Member
    Posted 5 years ago #

    Okay - I think I understood that now. I removed pieces of the code and it was okay. The image disappeared, but the page didn't break until I got to the first piece of the code here. This breaks it. Put it back and the page is good although the graphic doesn't show. Puzzling why this breaks it...

    <center>
    <link rel="stylesheet" href="http://victorycaucus.com/windowfiles/dhtmlwindow.css" type="text/css">
    <center />

    All this does, apparently, is call the stylesheet from the original souce of the form, plus the opening and closing center tags.

  5. iridiax
    Member
    Posted 5 years ago #

    The top center tag in this bit of code is actually improperly unclosed because the <center /> tag at the end is self-closed (a single opened and closed entity) due to the position of its slash. The link tag is also an error because these tags should be self-closed and belong in the document head, not in the body.

    Normally, removing bad code should improve things, but here it may weirdly be allowing other errors to show themselves or to set off error cascades. Check for any div errors as these tend to be some of the biggest culprits in misplaced sidebar issues.

  6. Saurus
    Member
    Posted 5 years ago #

    Yeah - I already did that and found no div errors. What's strange is that when this site link was still functioning the link worked just fine. It's only since it became inactive that these issues started. This entire piece of code was simply pasted into the sidebar 2 years ago, exactly as stated in the directions for the site.

    For now I guess I'll leave it be. My site is functioning normally now with the rest of that code removed.

  7. t31os
    Member
    Posted 5 years ago #

    Why all the <center> tags in the sidebar?...

    And i can't see the link you refer to, can you show me a screenshot?

    Perhaps one with the problem link, and one with the page when it's totally removed?

    Sidebar looks like it could do with a bit of a re-write, i can help if necessary...

    Are you using Widgets or hard-coded sidebar code?

  8. Saurus
    Member
    Posted 5 years ago #

    Why all the <center> tags in the sidebar?...
    All the divs are aligned center. Reason should be obvious.

    And i can't see the link you refer to, can you show me a screenshot?
    Cant's see it because the code was removed as previously stated:) Screenshot? No - not available.

    Perhaps one with the problem link, and one with the page when it's totally removed?

    Again, no. I'm not about to reload the code just to take a screenshot of each.

    Sidebar looks like it could do with a bit of a re-write, i can help if necessary...

    Re-write what, and why? Works fine, looks the way I want it.

    Are you using Widgets or hard-coded sidebar code?
    No widgets - hard coded. Theme isn't widgetized, nor is the version. Don't tell me to upgrade - that won't happen:)

  9. t31os
    Member
    Posted 5 years ago #

    I'm not talking purely about DIV elements, you have needless..

    <center>
    <div align="center">

    You're centering over and over again when you only need do it once or twice....

    I'm not telling you there's a problem with the code method you've chosen, but it most certainly can be improved upon, and reduced quite a bit...

    I'm quite happy to help with the problem link also, but without being able to see the problem link, be it on the page or a screenshot you've made it impossible to resolve. Then again you're happy leaving it there, so be it....

  10. Saurus
    Member
    Posted 5 years ago #

    Thanks for the offer, and I do appreciate it. However - I'm not going to reinstall the code just to show the link. I've displayed the total code in my OP on this, so why the need to actually SEE it escapes me. Code is code - who cares how it displays? This snippet is the graphic that displays with the link:

    The very first line of the code is what causes the break.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.