WordPress.org

Ready to get started?Download WordPress

Forums

Cannot redeclare validate_file()? (8 posts)

  1. Anonymous
    Unregistered
    Posted 6 years ago #

    Just installed 2.6 and ran upgrade.php, and got this.

    Fatal error: Cannot redeclare validate_file() (previously declared in /home/cmwong/domains/wetcalamari.net/public_html/wp-includes/functions.php:2238) in /home/cmwong/domains/wetcalamari.net/public_html/wp-admin/includes/file.php on line 73

    the directory doesn't contain file.php, and it didn't come in the distro either. Am I missing something?

  2. kevinhol
    Member
    Posted 6 years ago #

    I am having the same problem on two different sites. Anyone have any ideas about how to fix it?

  3. buchannon
    Member
    Posted 6 years ago #

    Same error here... what's going on?

  4. Lester Chan
    Member
    Posted 6 years ago #

    I would suggest deleting everything except /wp-content/ folder then upload WP2.6 again.

  5. kevinhol
    Member
    Posted 6 years ago #

    I deleted everything except the wp-content folder and the config file and installed WP2.6 and it worked. Not sure what I did the first time but that sovled the problem.

  6. Lester Chan
    Member
    Posted 6 years ago #

    I would always recommend you deleting everything and upload the new content instead of overwriting it.

  7. herko
    Member
    Posted 6 years ago #

    Thanks, this worked for me. Any thoughts on which file was the culprit?

  8. NilsHendriks
    Member
    Posted 6 years ago #

    I still get this error after I've deleted wp-admin and wp-includes and the root files (and re-uploaded of course) for several times now.

    I'll try putting back 2.5 but I doubt that it will work.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.