WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
[resolved] Cannot post to our Timeline (3 posts)

  1. gdtechllc
    Member
    Posted 1 year ago #

    We recently downloaded the plugin and created an app, but for some odd reason when we create a post, doesn't post to our facebook time line.
    we get this error:

    Failed posting to your Facebook Timeline. Error: {"message":"Object at URL 'http://thenavajopost.com/2012/11/13/test-2/' of type 'website' is invalid because a required property 'og:type' of type 'string' was not provided.","type":"Exception"}

    http://wordpress.org/extend/plugins/facebook/

  2. Niall Kennedy
    Member
    Plugin Author

    Posted 1 year ago #

    I took a look at the referenced URL.

    You have multiple html elements on the page (see: line 1, line 73), very likely to cause parse errors as Facebook or Google tries to understand your page content.

    On line 34 your page outputs an "og:type" property containing HTML. This property was not output by the Facebook plugin.

    On line 195 the Facebook plugin outputs a correct Open Graph protocol type of "article."

    1. Validate your page HTML against the W3C Validator to highlight parser errors from a general page parsing point of view.
    2. Test your site in the Facebook debugger for Facebook-specific parsing information.
  3. gdtechllc
    Member
    Posted 1 year ago #

    I am not too familiar with this, I did do what you suggested with the Facebook debugger and got this, as follows:

    Like Button Warnings That Should Be Fixed
    Like Button Tag Missing: og:image is missing. The og:image meta tag is necessary for Facebook to render a News Feed story that generates a high click-through rate.

    Open Graph Warnings That Should Be Fixed
    Inferred Property: The 'og:image' property should be explicitly provided, even if a value can be inferred from other tags.
    Small og:image: All the images referenced by og:image should be at least 200px in both dimensions. Please check all the images with tag og:image in the given url and ensure that it meets the recommended specification.
    Mismatch og:url and canonical url: og:url tag in the header is not the same URL as rel='canonical' link in the html.

    Can you please elaborate in laymen terms? Thank you very much. Is this a simple fix?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic