WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Landing Pages
[resolved] Cannot Perform Plugin or WordPress Updates (16 posts)

  1. atjackson45
    Member
    Posted 1 year ago #

    With landing page plugin installed, I am unable to update any plugins or wordpress.

    error:
    Downloading update from http://downloads.wordpress.org/plugin/jetpack.2.1.1.zip…

    Download failed. Couldn't resolve host 'downloads.wordpress.org'

    I am also unable to view update details.
    error:
    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems.

    http://wordpress.org/extend/plugins/landing-pages/

    This was tested with a new installation and only with the landing page plugin active.

    It doesn't happen when the plugin is deactivated.

  2. atjackson45
    Member
    Posted 1 year ago #

    This was tested with a new installation and only with the landing page plugin active.

    It doesn't happen when the plugin is deactivated.

  3. Hudson Atwell
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Atjackson45

    Cheers.

    I just ran an plugins update test on a plugin while Landing Pages was installed and activated.

    http://screencast.com/t/5KZu36gkKq19

    I was also able to update WordPress core to 3.5.1 shortly afterward.

    I'm interested in your progress on this. Can you confirm if it happens on any of your other blogs? Also what version WordPress?

    -H

  4. atjackson45
    Member
    Posted 1 year ago #

    Hey Hudson,

    I am not sure why the issue is happening for me and not you, I have tried an alternate clean install but I am still unable to have the same results as you have.

    Here is a screencast. This shows what happens when I try to update a plugin and use buddypress menu items linking to the wordpress pages before and after installing landing pages.

    http://screencast.com/t/YMgk5hsmnAr

    Let me know if we can sync up.

    Thanks
    Tara

  5. atjackson45
    Member
    Posted 1 year ago #

    Here is another screencast with another installation.

    http://screencast.com/t/ytItua9JVad

  6. atjackson45
    Member
    Posted 1 year ago #

    To answer your previous question, the WordPress version is 3.5.1

    I want to release this to my members by Friday but I cannot if the issue still remains.

    Could we set up some time to allow your developer to look at our site and see if they could debug the issue?

    Thanks
    Tara

  7. Hudson Atwell
    Member
    Plugin Author

    Posted 1 year ago #

    Sure Tara, will you apply for advanced support here?
    It's really busy over in my parts but I'll take a look asap.

    http://plugins.inboundnow.com/advanced-support/

  8. atjackson45
    Member
    Posted 1 year ago #

    Awesome thanks, I filled out the support request.

  9. atjackson45
    Member
    Posted 1 year ago #

    Hey Hudson,

    I have quite a few wordpress websites, so I decided to install the plugin on another website to see if the issue was still occurring:

    JacksonCantu
    http://screencast.com/t/leqFM7pr3G

    The issue is still happening but it now displays the error:

    An Unexpected HTTP error occurred during the API Request.

  10. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    Hey atjackson45,

    I see what you mean. it looks like the it's timing out when connected to the wp plugin repo.

    Solution 1:
    From: http://wordpress.org/support/topic/an-unexpected-http-error-occurred-during-the-api-request-how-to-fix-it?replies=39

    Edit file plugin-install.php
    in directory wp-admin/includes
    and find the timeout setting. It is by default set to 15. Increase to 60.
    $request = wp_remote_post('http://api.wordpress.org/plugins/info/1.0/', array( 'timeout' => 60, 'body' => array('action' => $action, 'request' => serialize($args))) );

    Possible solution 2:
    Install http://wordpress.org/extend/plugins/hotfix/ and it fixes common wp bugs, including http timeouts.

    I've tried to replicate what you show in the video on 3 different sites on localhost, and two different live servers and cannot replicate the issue.

    Let me know if either of the two solutions don't work and we will dive even deeper =)

  11. atjackson45
    Member
    Posted 1 year ago #

    Hey David,

    Thank you for taking your time to help me debug this issue.

    Things I Have Tried

    I tried both solutions and neither solution worked.

    I have tested the memory_limit raised it to 500M and saw that it was changed in phpinfo().

    I have deactivated all plugins and and return theme to wordpress default, then reactivated only the landing page plugin.

    Installed the hotfix plugin

    Changed the timeout setting to 60.

    Similarities I Noticed

    All of these websites are hosted on Hostgator. Could there be an issue with this?

    Thanks for you time,

    Tara

  12. David Wells
    Member
    Plugin Author

    Posted 1 year ago #

    Hmmm.

    Yep it might be a host issue. Like they changed server file permissions on the past plugins or something.

    Can you update the plugins when landing pages is not installed?

    -David

  13. atjackson45
    Member
    Posted 1 year ago #

    Yes, the issue only happens with the landing page plugin is active.

    - It will occasionally give me 404 pages on pages but after refreshing the page it will show.
    - I can't update plugins.

    These issues only happen when the plugin is active.

    My conclusion is that it may have something to do with Hostgator since all of the website that I tested this plugin on are using hostgator and have the same issue.

    I wonder if the plugin causes some flag for a security rule or memory_limit issue with host gator but I am not sure.

    Thanks
    Tara

  14. hinesfitchbros
    Member
    Posted 1 year ago #

    i have the same problem. when i deactivate this plugin, i'm able to update other plugins. when it's activated, i can't update any plugins. i also use hostgator.

  15. Hudson Atwell
    Member
    Plugin Author

    Posted 1 year ago #

    Hey guys we found the fix and an update is in place on 1.0.3.9. Committing the new files in about 10 minutes.

    Will you confirm if the issue is solved after updating?

  16. atjackson45
    Member
    Posted 1 year ago #

    Hudson it works!

    Thank you for taking so much of your time to find a solution for hostgator.

    All of the tickets I created have now been fixed with this fix.

    The new plugin version is installed and working as expected and we appreciate it. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic