WordPress.org

Ready to get started?Download WordPress

Forums

Cannot modify header information - headers already sent by (22 posts)

  1. rvnder
    Member
    Posted 1 year ago #

    Warning: Cannot modify header information - headers already sent by (output started at /home/affiliat/public_html/wp-config.php:1) in /home/affiliat/public_html/wp-includes/pluggable.php on line 881

    unable to login wp-admin panel

    here is my wp-config.php

    <?php
    define('DB_NAME', 'affiliat_wrdp1');
    
    /** MySQL database username */
    define('DB_USER', 'affiliat_wrdp1');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'MODREMOVED');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'MODREMOVED');
    define('SECURE_AUTH_KEY',  'MODREMOVED');
    define('LOGGED_IN_KEY',    'MODREMOVED');
    MOD: KEYS REMOVED FOR SECURITY );
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress. A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
     * language support.
     */
    define('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
        define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    [mod: never post any passwords or security codes]

  2. 360
    Member
    Posted 1 year ago #

    Hi,

    as the mod already said - the wp-config.php file is the heart of your site. it includes sensitive login informations.

    the config looks good and nothing wrong with it.
    maby a plugin or theme is causing the error.
    Please try to deactivate all plugins and see if you still get the error.
    Activate the plugins one by one to hunt down the bug.
    btw: where do you get the error message? in wp-admin? frontend?

  3. rvnder
    Member
    Posted 1 year ago #

    yes .. each time i try to login wp-admin ..

  4. rvnder
    Member
    Posted 1 year ago #

    i rename the all plugins and deactivate them . but still having the same error..

  5. esmi
    Forum Moderator
    Posted 1 year ago #

  6. rvnder
    Member
    Posted 1 year ago #

    Sir already every thing they said

    1, remove spaces
    2, disable plugins

    everythinggggggggggggggggggggggggggg

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    Well, it sounds as if you still have non-printable (invisible) characters at the start of your wp-config.php file. What are you using to edit this file?

  8. rvnder
    Member
    Posted 1 year ago #

    notepad

  9. rvnder
    Member
    Posted 1 year ago #

    and dreamweaver

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    Open the file in NotePad again.
    Place the cursor between the first < and the start of the file
    Now press the BACKSPACE key on your computer and hold it for at least 15 seconds.
    Save the file and re-upload it using FTP or whatever file management application your host provides. Do NOT use Dreamweaver.

  11. rvnder
    Member
    Posted 1 year ago #

    Checked . Not progress same error..

    check by your self http://affiliatesurge.com.au/

    try to login http://affiliatesurge.com.au/wp-admin/

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    Try re-creating your wp-config.php from scratch using wp-config-sample.php as a template. again, use Notepad - not Dreamweaver.

  13. rvnder
    Member
    Posted 1 year ago #

    how ?? can i just make anew file wp-config.php or just rename wp-confif.php ??

    [Please stop posting in uppercase. It's the electronic equivalent of shouting and is considered quite rude. Post de-capped.]

  14. rvnder
    Member
    Posted 1 year ago #

    i edit sample now get this error

    Parse error: syntax error, unexpected $end in /home/affiliat/public_html/wp-config.php on line 1

  15. rvnder
    Member
    Posted 1 year ago #

    i back upload old wp-confg bow getting same error

    :(

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    I;m really sorry but there's nothing else we can do to hep you. The issues are definitely related to your creation/editing of your wp-config.php file. Is WordPress installed on your site yet?

  17. rvnder
    Member
    Posted 1 year ago #

    above i pasted my wp-config file can you copy and send me in write way. if you think i am missing something in tht file ??

  18. esmi
    Forum Moderator
    Posted 1 year ago #

    Is WordPress installed on your site yet?

  19. rvnder
    Member
    Posted 1 year ago #

    yes.....this is word-press site ... r you talking about new installation of WordPress ??

  20. esmi
    Forum Moderator
    Posted 1 year ago #

    Is WordPress installed on your site yet?

  21. rvnder
    Member
    Posted 1 year ago #

    yes........

  22. esmi
    Forum Moderator
    Posted 1 year ago #

    In that case, I suggest you consider hiring someone to carry out the necessary work for you.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.