WordPress.org

Ready to get started?Download WordPress

Forums

Cannot modify header information (4 posts)

  1. diabolus
    Member
    Posted 6 years ago #

    Hi....

    I've switched to the new hosting provider, and have installed wp v2.2.1 via cpanel/fantastico, have restored my previous wp blog sql via phpmyadmin too. lastly, have upgraded my wp from 2.2.1 (this version is in fantastico) to 2.2.2 (manual upgrade). there's NO error in upgrade proccess, but after that, when i try to log in to wp-admin i get error like below:


    Warning: Cannot modify header information - headers already sent by (output started at /home/aufkgorg/public_html/wp-config.php:25) in /home/aufkgorg/public_html/wp-login.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /home/aufkgorg/public_html/wp-config.php:25) in /home/aufkgorg/public_html/wp-includes/pluggable.php on line 369

    Warning: Cannot modify header information - headers already sent by (output started at /home/aufkgorg/public_html/wp-config.php:25) in /home/aufkgorg/public_html/wp-includes/pluggable.php on line 370

    Warning: Cannot modify header information - headers already sent by (output started at /home/aufkgorg/public_html/wp-config.php:25) in /home/aufkgorg/public_html/wp-includes/pluggable.php on line 331

    i've checked these file, but i don't know what must i edit :( please give help !

    thanks

  2. whooami
    Member
    Posted 6 years ago #

    when you edited your wp-config.php to reflect the new settings you either introduced spaces or line breaks before the opening <?php or after the closing ?>

    Open that file, locate, and remove the spaces or linebreaks.

    and judging by the line number -- it looks its the after the closing ?>

  3. diabolus
    Member
    Posted 6 years ago #

    oh thanks a million for your ultra great solution, now my wp is normally, god bless you :)

    hmm.. once again, i want to know the way to change the author post in all previous post, because in my new blog, i use different admin name !

    i tried from admin area >> users >> and choose the previous admin name >> but in the name box, my previous admin name can't be clicked:


    Name
    Username: (no editing)

    so, please tell me !
    cheers,

  4. nun
    Member
    Posted 6 years ago #

    whooami -- I can't tell you how relieved I am to have found your advice. I had to edit my wp-config and i think my text editor must have added the lines. Would never have known to look there if it weren't for you. Sure enough a couple extra lines were there. Fixed it and now I can access my admin. Thanks so much.

Topic Closed

This topic has been closed to new replies.

About this Topic